Bug 1275925 - [New] - Message displayed after attach tier is misleading
[New] - Message displayed after attach tier is misleading
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
medium Severity low
: ---
: RHGS 3.1.2
Assigned To: hari gowtham
Bhaskarakiran
: ZStream
Depends On:
Blocks: 1260783 1260923 1277081 1277800
  Show dependency treegraph
 
Reported: 2015-10-28 02:51 EDT by RamaKasturi
Modified: 2016-11-23 18:11 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1277081 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:46:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 05:20:36 EST

  None (edit)
Description RamaKasturi 2015-10-28 02:51:59 EDT
Description of problem:
When user does a attach tier the message displayed reads "volume rebalance: vol_ec: success: Rebalance on vol_ec has been started successfully. Use rebalance status command to check status of the rebalance process.
ID: dd623d49-6077-46d6-a4af-88ce2b40436f"

Message displayed after attach tier needs to be changed as this could be confusing.


Version-Release number of selected component (if applicable):
glusterfs-3.7.5-0.3.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a volume
2. Attach  tier to the volume.
3. 

Actual results:
Once the tier is attached successfully, a message is displayed which reads rebalance started sucessfully and use the rebalance status command to check the status.

Expected results:
Message in the description should not be displayed as this is confusing to the user. display a message saying attach tier is successful, use tier status to check the status.
Additional info:
Comment 3 Bhaskarakiran 2015-11-17 07:14:18 EST
Verified this on 3.7.5-6. Message is changed as intended.

[root@transformers ~]# gluster v attach-tier vol1  rep 2 transformers:/rhs/brick10/vol1-tier1 interstellar:/rhs/brick10/vol1-tier2 transformers:/rhs/brick11/vol1-tier3 interstellar:/rhs/brick11/vol1-tier4
volume attach-tier: success
Tiering Migration Functionality: vol1: success: Attach tier is successful on vol1. use tier status to check the status.
ID: 47aeefca-6387-423a-9c2e-ec28880f4c42
Comment 5 errata-xmlrpc 2016-03-01 00:46:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.