Bug 1275936 - nova searches for wrong device unexpectedly when multipath device has faulty lun
nova searches for wrong device unexpectedly when multipath device has faulty lun
Status: CLOSED DUPLICATE of bug 1275937
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 03:03 EDT by Chen
Modified: 2015-10-30 12:47 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 12:47:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chen 2015-10-28 03:03:01 EDT
Description of problem:

nova searches for wrong device unexpectedly when multipath device has faulty lun

The error message is something following:

TRACE nova.compute.manager [instance: d9db6ec9-0758-4565-acd8-e06bd6a29c3a] libvirtError: Cannot access storage file '/dev/mapper/Oct' (as uid:107, gid:107): No such file or directory

As the above we can see that nova-compute is looking for a device called /dev/mapper/Oct.

Version-Release number of selected component (if applicable):

OSP 6.0 on RHEL 7

How reproducible:



Steps to Reproduce: ( according to the customer )
1. Make one lun faulty in multipath device
2. Start a nova instance
3. Check the nova-compute.log

Actual results:

A wrong device ( /dev/mapper/Oct ) is used

Expected results:

The instance should boot normally.

Additional info:
Comment 2 Lee Yarwood 2015-10-30 12:47:21 EDT

*** This bug has been marked as a duplicate of bug 1275937 ***

Note You need to log in before you can comment on or make changes to this bug.