Bug 1275941 - Guest network becomes unreachable with bridge e1000 after hotplug memory
Guest network becomes unreachable with bridge e1000 after hotplug memory
Status: CLOSED DUPLICATE of bug 1271527
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 03:09 EDT by Yumei Huang
Modified: 2016-01-20 05:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 05:37:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yumei Huang 2015-10-28 03:09:57 EDT
Description of problem:
With bridge e1000, guest network becomes unreachable after hotplug memory 256 times. Virtio-net-pci and rtl8139 works well.


Version-Release number of selected component (if applicable):
kernel: 3.10.0-326.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. launch a guest with cmd:
/usr/libexec/qemu-kvm -name rhel72-sn5 -m 1G,slots=256,maxmem=40G \

-numa node -smp 4,sockets=4,cores=1,threads=1 \

-no-user-config -nodefaults -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -boot menu=on,strict=on \

-object iothread,id=iothread0 -drive file=/home/guest/rhel72-sn5.img,if=none,id=drive-data-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop  -device virtio-blk-pci,drive=drive-data-disk,id=data-disk,iothread=iothread0,bus=pci.0,addr=0x7 \

-netdev tap,id=hostnet1,vhost=on -device e1000,netdev=hostnet1,id=net2,mac=10:1a:4a:42:0a:0b,bus=pci.0,addr=0xa \

-usb -device usb-tablet,id=input0 -vga qxl \

-spice port=5901,addr=0.0.0.0,disable-ticketing,image-compression=off,seamless-migration=on -monitor unix:/tmp/monitor3,server,nowait

2. Hotplug 128M memory to guest 256 times with script:
#!/bin/bash 
i=0 
while [ $i -lt 256 ] 
do 
echo $i 
sleep 3 
echo "object_add memory-backend-ram,id=mem$i,size=128M"|nc -U /tmp/monitor3 
sleep 2 
echo "device_add pc-dimm,id=dimm$i,memdev=mem$i,slot=$i"|nc -U /tmp/monitor3 
i=$(($i+1)) 
done 

3. Ping host inside guest


Actual results:
Destination Host Unreachable.

Expected results:
Can ping host well.

Additional info:
Comment 2 Yumei Huang 2015-10-30 04:35:20 EDT
I also found after hotplug memory with 512M once, then reboot the guest, the guest network becomes unreachable too.  But with 128M and 256M, the network works well.
Comment 3 Igor Mammedov 2016-01-20 05:37:07 EST

*** This bug has been marked as a duplicate of bug 1271527 ***

Note You need to log in before you can comment on or make changes to this bug.