Bug 127595 - Kernel does not include ieee802_11.h - so Intel centrino drivers cannot be compiled
Kernel does not include ieee802_11.h - so Intel centrino drivers cannot be co...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 21:49 EDT by Sergey V. Udaltsov
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 11:09:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2004-07-09 21:49:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040618 Galeon/1.3.16

Description of problem:
Trying to build ipw Intel wifi drivers, I get this error: 

/home/svu/ipw2100-0.49/ieee80211_module.c:54:24: ieee802_11.h: No such
file or directory
In file included from /home/svu/ipw2100-0.49/ieee80211_module.c:55:
/home/svu/ipw2100-0.49/ieee80211.h:48:24: ieee802_11.h: No such file
or directory
In file included from /home/svu/ipw2100-0.49/ieee80211_module.c:55:
/

In earlier versions of the kernel, the file existed.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.457

How reproducible:
Always

Steps to Reproduce:
1. Take ipw2100 driver from ipw2100.sf.net
2. Try to build it against installed kernel
3.
    

Actual Results:  The error (mentioned above)

Expected Results:  Driver to be built

Additional info:
Comment 1 Bill Nottingham 2004-08-05 15:59:19 EDT
It was moved to drivers/net/wireless, IIRC.
Comment 2 Sergey V. Udaltsov 2004-08-05 18:10:06 EDT
Bill - sorry, but it is not in kernel-2.6.*i686.rpm. That is why I
filed this bug. Are you saying I should look at different rpm?
Comment 3 Sergey V. Udaltsov 2004-08-05 18:11:57 EDT
I mean ieee802_11.h, of course. Or did you mean the intel's centrino
driver?
Comment 4 Bastien Nocera 2004-08-26 11:09:20 EDT
It's in the FAQ:
http://ipw2100.sourceforge.net/faq.php#qa_3_1
Comment 5 Sergey V. Udaltsov 2004-08-26 11:18:19 EDT
Well, I don't mind. That's what I am doing. But is there any special
reason NOT to include this header?
Comment 6 Bastien Nocera 2004-08-26 13:17:39 EDT
The header is in the kernel-source package. I think that the reason
why it's not readily available to drivers is because it's supposed to
be private, for now, while work is ongoing to consolidating the
wireless drivers. Your best bet is to either change the include
directories used by the ipw2x00 drivers, or simply keep on copying
that file to the source directory.

Note You need to log in before you can comment on or make changes to this bug.