This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275966 - RFE : Exporting multiple subdirectory entries for gluster volume using cli
RFE : Exporting multiple subdirectory entries for gluster volume using cli
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
mainline
All All
high Severity high
: ---
: ---
Assigned To: bugs@gluster.org
: FutureFeature, Triaged
Depends On:
Blocks: 1275973
  Show dependency treegraph
 
Reported: 2015-10-28 04:47 EDT by Jiffin
Modified: 2016-06-16 09:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1275973 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-10-28 04:47:25 EDT
Description of problem:

As per current design ,it is only possible to export one path for a volume using nfs-ganesha at a time.Although it can be performed using manual configuration of export file , but it has its own limitations.

Version-Release number of selected component (if applicable):
mainline
Comment 1 Vijay Bellur 2016-02-09 06:08:20 EST
REVIEW: http://review.gluster.org/13283 (NFS-Ganesha : scripts related changes for supporting multiple export entires for volume) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-03-01 03:00:09 EST
COMMIT: http://review.gluster.org/13283 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit ea00992d3d52a51b7c8311ad9565bbbb6e395f9d
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Fri Jan 22 17:47:07 2016 +0530

    NFS-Ganesha : scripts related changes for supporting multiple export entires for volume
    
    Previously script such as dbus-send.sh, ganesha-ha.sh can handle only one EXPORT{} block.
    
    Change-Id: I2286af4877f96f4334435818f67beea87efa2b1f
    BUG: 1275966
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13283
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 3 Vijay Bellur 2016-03-11 04:21:36 EST
REVIEW: http://review.gluster.org/13673 (Revert "NFS-Ganesha : scripts related changes for supporting multiple export entires for volume") posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2016-03-18 06:18:25 EDT
REVIEW: http://review.gluster.org/13673 (Revert "NFS-Ganesha : scripts related changes for supporting multiple export entires for volume") posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 5 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Vijay Bellur 2016-04-24 10:04:03 EDT
REVIEW: http://review.gluster.org/13673 (Revert "NFS-Ganesha : scripts related changes for supporting multiple export entires for volume") posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 7 Vijay Bellur 2016-04-24 10:30:17 EDT
REVIEW: http://review.gluster.org/13673 (Revert "NFS-Ganesha : scripts related changes for supporting multiple export entires for volume") posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 8 Vijay Bellur 2016-04-24 10:30:20 EDT
COMMIT: http://review.gluster.org/13673 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 62027360a695ff499c0492f1bc37f585ed4576c1
Author: jiffin tony Thottan <jthottan@redhat.com>
Date:   Thu Mar 10 04:03:19 2016 -0800

    Revert "NFS-Ganesha : scripts related changes for supporting multiple export entires for volume"
    
    This reverts change-id I2286af4877f96f4334435818f67beea87efa2b1f.
    While testing, I had found that ganesha-ha.sh is not working as expected. It is
    almost equivalent to rewrite entire thing again
    
    Change-Id: Ia85e50fe8e043e8a2bc6441b7c45dcc726b36672
    BUG: 1275966
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13673
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 9 Niels de Vos 2016-06-16 09:41:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.