Bug 1275983 - [intservice_public_91]got 'Error from server: 502' when try to deploy logging-kibana
[intservice_public_91]got 'Error from server: 502' when try to deploy logging...
Status: CLOSED DUPLICATE of bug 1273149
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
chunchen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 05:44 EDT by wyue
Modified: 2016-09-29 22:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 08:20:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wyue 2015-10-28 05:44:22 EDT
Description of problem:
Got below error when I try to deploy logging-kibana with 'oc deploy logging-kibana --latest'

Error from server: 502:  (unhandled http status [Request Entity Too Large] with body []) [0]


Version-Release number of selected component (if applicable):
openshift v3.0.2.903-74-gf49cee6
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
sometimes

Steps to Reproduce:
1.deploy EFK stack according to :
https://github.com/openshift/origin-aggregated-logging/tree/master/deployment

2.wait for the deployments complete and found both deployments are error.
(both deployment fail because pods took longer than 600 seconds to become ready)
[root@dhcp-128-16 ~]# oc get pods
NAME                           READY     STATUS        RESTARTS   AGE
logging-deployer-6hb70         0/1       Completed     0          23m
logging-es-36n5hs16-1-deploy   0/1       Error         0          19m
logging-kibana-1-deploy        0/1       Error         0          19m

3.
deploy logging-es-36n5hs16 with 'oc deploy logging-es-36n5hs16 --latest', the deploy pod starts.
then try to deploy kibana with 'oc deploy logging-kibana --latest'

Actual results:
[root@dhcp-128-16 ~]# oc deploy logging-kibana --latest
Error from server: 502:  (unhandled http status [Request Entity Too Large] with body []) [0]

Expected results:
deployment should start correctly

Additional info:
[root@dhcp-128-16 ~]# oc get is
NAME                    DOCKER REPO                                       TAGS                                                                                                                   UPDATED
logging-auth-proxy      172.30.7.188:5000/logging/logging-auth-proxy      3.1-2,rhose-3.1-rhel-7-docker-candidate-20151016172152,3.1-3 + 9 more...                                               2 hours ago
logging-elasticsearch   172.30.7.188:5000/logging/logging-elasticsearch   rhose-3.1-rhel-7-docker-candidate-20151018221133,rhose-3.1-rhel-7-docker-candidate-20151020135843,3.1-7 + 15 more...   2 hours ago
logging-fluentd         172.30.7.188:5000/logging/logging-fluentd         3.1-1,3.1-4,rhose-3.1-rhel-7-docker-candidate-20151016172759 + 7 more...                                               2 hours ago
logging-kibana          172.30.7.188:5000/logging/logging-kibana          3.1-1,3.1-3,rhose-3.1-rhel-7-docker-candidate-20151015084248 + 3 more...                                               2 hours ago
Comment 2 Luke Meyer 2015-10-29 11:40:04 EDT
I haven't seen this and can't imagine what is going on. "Error from server" seems to indicate the OpenShift master is having problems unrelated to logging. I'm not sure what to do with this.
Comment 3 Luke Meyer 2015-10-30 08:20:40 EDT
Appears to be a symptom of the problem in https://bugzilla.redhat.com/show_bug.cgi?id=1273749 which I hypothesize is just https://bugzilla.redhat.com/show_bug.cgi?id=1273149 showing up in 3.1. Re-open to investigate once that bug is resolved.

*** This bug has been marked as a duplicate of bug 1273149 ***

Note You need to log in before you can comment on or make changes to this bug.