Bug 12760 - Login/cookie inconsistencies, please fix!
Login/cookie inconsistencies, please fix!
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-20 11:52 EDT by giulioo
Modified: 2007-04-18 12:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 11:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-06-20 11:52:22 EDT
My fault is that I use ie5.

1)
I open the browser, go to:
http://bugzilla.redhat.com/bugzilla/
and the grey bar says
login: giulioo@pobox.com

2)
I choose "query bug .."
The query page opens and the grey bar says
"not logged in"

3)
I press the "login" link, login, now the query page says
login: giulioo@pobox.com

4) 
Query bugzilla bugs, want to add one, "add bug" and buzilla tells me "You 
are not logged in, login to ..."

Why?? 
Every time I browse bugzilla I'm randomly asked to login. I deleted all 
the cookies. The bug is still there.
Remember that bugzilla has problems setting cookies to ie5 browsers, see 
#11975.

If you add the 1 minute freeze every time you select a new product in the 
query page, you understand bugzilla is almost unusable since the switch to 
Oracle, at least for ie5 users...
Comment 1 Daniel Roesen 2000-09-26 13:33:59 EDT
Confirmed for IE4 except for the 1 minute freeze. This is _really_ annoying.
Comment 2 Milan Kerslager 2001-07-26 00:18:21 EDT
Yes, Bugzilla tell me that I'm logged-in, but when I switch to another bug (by 
cut'n'pasting new URL to my browser) I'm no longer authenticated even I can see 
my login-name on the top of the page. When then I try to submit some report 
(still can see: Login: milan.kerslager@spsselib.hiedu.cz on the top of the 
page), Bugzilla tell me (after submiting some comment) that I need to re-login.

Also even my name is on the top of the page I'm unable to change bug's 
properties (ie reopen bug etc). After hitting submit button and Bugzilla's 
complain about that I'm not logged-in and filling again my login this is 
possible to do what I want. Sure after filling new URL in my browser, the story 
is the same again.

This is 100% reproducible. I tryed various versions od MSIE (5.5 SP1 too) and 
Mozilla too.
Comment 3 Milan Kerslager 2004-09-21 11:08:38 EDT
It seems to work for some time so closing this wery old bug.

Note You need to log in before you can comment on or make changes to this bug.