Bug 127600 - Running ethereal over cygwin crashes
Summary: Running ethereal over cygwin crashes
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ethereal   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-10 14:57 UTC by Kenneth Porter
Modified: 2015-03-05 01:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 14:43:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenneth Porter 2004-07-10 14:57:56 UTC
Start ethereal from a Cygwin window on Win2k, then mouse over the
capture button. Ethereal exits with the following info. (RPM package
version follows.) Cygwin DLL is 1.5.10. Cygwin xorg-x11-base is 6.7.0.0-8.

[root@newred RPMS]# ethereal --sync
The program 'ethereal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 2770 error_code 3 request_code 38 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
[root@newred RPMS]# rpm -qa | grep ether
ethereal-gnome-0.10.3-2.2
ethereal-0.10.3-2.2

Comment 1 Phil Knirsch 2004-07-14 14:07:36 UTC
To be honest, i have no clue how to debug this as i have only Linux
machines here.

Maybe one of our Cygwin developers has an idea.

Read ya, Phil

Comment 2 Phil Knirsch 2004-07-14 14:43:24 UTC
OK, i've been discussing that problem with our Cygwin developer.

The problem is almost certainly in the Cygwin X server on the Win2k
machine (despite the error message stating differently).

Unfortunately that X server is not supported or developed on here at
Red Hat.

But for more information about the Cygwin X server please check out
the mailinglist cygwin-xfree@cygwin.com where you should be able to
get a solution for your problem.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.