Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1276000 - WARN messages "Getting metric ["xxx"] at [...] failed: JBAS014792: Unknown attribute "yyy", rolled-back=true" is logged in the JON Agent log file
Summary: WARN messages "Getting metric ["xxx"] at [...] failed: JBAS014792: Unknown at...
Keywords:
Status: CLOSED DUPLICATE of bug 1276035
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: JON Plugin
Version: 6.5.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 6.6.0
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On: 1168255
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-28 10:54 UTC by bkramer
Modified: 2016-01-22 14:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-22 14:27:22 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-5901 0 Major Resolved Metrics not registered for local caches 2016-05-20 14:21:24 UTC
Red Hat Knowledge Base (Solution) 1235593 0 None None None Never

Description bkramer 2015-10-28 10:54:04 UTC
Description of problem:

Monitoring JDG 6.5.1 using JBoss ON 3.3.3 (with the latest version of JDG plugin for JBoss ON (Data Grid Management Plug-in Pack Update-03 for JBoss ON 3.3 [1]) fails and WARN messages like the following are logged in the agent.log file:

*************************************************************
2015-10-28 10:28:31,197 WARN  [ResourceContainer.invoker.daemon-9] (org.infinispan.server.rhq.IspnCacheComponent)- Getting metric [hitRatio] at [ Address{path: subsystem=infinispan,cache-container=local,local-cache=default}] failed: JBAS014792: Unknown attribute hit-ratio, rolled-back=true
*************************************************************

Here is complete list of metrics whose collection fails with the same WARN message as above: 

hitRatio                Unknown attribute hit-ratio, rolled-back=true
readWriteRatio          Unknown attribute read-write-ratio, rolled-back=true
replicationCount        Unknown attribute replication-count, rolled-back=true
timeSinceReset          Unknown attribute time-since-reset, rolled-back=true
commits                 Unknown attribute commits, rolled-back=true
rollbacks               Unknown attribute rollbacks, rolled-back=true
averageReplicationTime  Unknown attribute average-replication-time, rolled-back=true
successRatio            Unknown attribute success-ratio, rolled-back=true
removeHits              Unknown attribute remove-hits, rolled-back=true
evictions               Unknown attribute evictions, rolled-back=true
removeMisses            Unknown attribute remove-misses, rolled-back=true
prepares                Unknown attribute prepares, rolled-back=true
averageReadTime         Unknown attribute average-read-time, rolled-back=true
elapsedTime             Unknown attribute elapsed-time, rolled-back=true
hits                    Unknown attribute hits, rolled-back=true
replicationFailures     Unknown attribute replication-failures, rolled-back=true
misses                  Unknown attribute misses, rolled-back=true
stores                  Unknown attribute stores, rolled-back=true
numberOfEntries         Unknown attribute number-of-entries, rolled-back=true
averageWriteTime        Unknown attribute average-write-time, rolled-back=true
averageRemoveTime       Unknown attribute average-remove-time, rolled-back=true

If you enable [CasheStore]Number of cache store stores for Cache resource in JBoss ON - the following is logged:

****************************************************************
2015-10-28 10:28:31,525 WARN  [ResourceContainer.invoker.daemon-9] (org.infinispan.server.rhq.IspnCacheComponent)- Getting metric [cacheLoaderStores] at [ Address{path: subsystem=infinispan,cache-container=local,local-cache=default}] failed: JBAS014792: Unknown attribute cache-loader-stores, rolled-back=true
****************************************************************

Above message previously was logged in https://bugzilla.redhat.com/show_bug.cgi?id=1168255. According to this Bugzilla above is fixed in JDG 6.4.1. However, JDG 6.5.1 still has the same problem. 


Version-Release number of selected component (if applicable):
JDG 6.5.1
JBoss ON 3.3.3
Data Grid Management Plug-in Pack Update-03 for JBoss ON 3.3 [1]

How reproducible:
Always

Steps to Reproduce:
1. JDG started invoking $JDG-HOME/bin/standalone.sh script
2. Navigate to JBoss ON UI -> JDG resource -> infinispan -> Cache Containers -> local -> Caches -> default -> Monitoring -> Metrics
3. Confirm that agent.log file contains WARN messages like above.
4. Navigate to any other tab for this resource (default - Cache) and the same set of WARN messages will be logged.
5. Navigate to Monitoring -> Schedules and enable [CacheStore]Number of cache store stores metrics;
6. Navigate to Monitoring -> Metrics;
7. Confirm that agent.log file contains the same set of WARN messages plus message for cahceLoaderStores.

Actual results:
WARN messages are logged in the agent.log file and metrics in JBoss ON UI show NaN values.

Expected results:
Agent.log file does not contain WARN messages and metrics are properly collected and shown in JBoss ON UI.

Additional info:
[1] https://access.redhat.com/jbossnetwork/restricted/softwareDownload.html?softwareId=39403

Comment 4 Tristan Tarrant 2015-10-30 13:00:33 UTC
The issue here is that we really only test with shared-state caches (replicated/distributed) in client/server mode and that's why this bug went unnoticed.

Comment 5 Martin Gencur 2015-10-30 15:22:21 UTC
Sorry Tristan but I have to correct you. This bug was reported a long time ago: https://bugzilla.redhat.com/show_bug.cgi?id=1181252 So BZ1276000 is actually a duplicate of 1181252. It was decided not to fix this in JDG 6.4 and was re-scheduled to JDG 6.6. See comments in BZ1181252.

Comment 9 Tristan Tarrant 2016-01-22 14:27:22 UTC
This is fixed in

*** This bug has been marked as a duplicate of bug 1276035 ***


Note You need to log in before you can comment on or make changes to this bug.