Bug 1276027 - [abrt] zsh: charrefinc(): zsh killed by SIGSEGV
[abrt] zsh: charrefinc(): zsh killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1245116
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:effcd7d968f4eeea99780dc5d7e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 08:26 EDT by Matthias Scholz
Modified: 2015-12-07 14:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 06:30:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.95 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: core_backtrace (19.82 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: dso_list (1.92 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: environ (2.59 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: maps (9.28 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: mountinfo (3.50 KB, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: open_fds (190 bytes, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: proc_pid_status (1013 bytes, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details
File: var_log_messages (303 bytes, text/plain)
2015-10-28 08:26 EDT, Matthias Scholz
no flags Details

  None (edit)
Description Matthias Scholz 2015-10-28 08:26:14 EDT
Version-Release number of selected component:
zsh-5.0.8-5.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/zsh
crash_function: charrefinc
executable:     /usr/bin/zsh
global_pid:     4383
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 charrefinc at pattern.c:1909
 #1 patmatch at pattern.c:2546
 #2 pattryrefs at pattern.c:2286
 #3 pattry at pattern.c:2005
 #4 execcase at loop.c:612
 #5 execcmd at exec.c:3405
 #6 execpline2 at exec.c:1717
 #7 execpline at exec.c:1500
 #8 execlist at exec.c:1276
 #9 execif at loop.c:530

Potential duplicate: bug 1245116
Comment 1 Matthias Scholz 2015-10-28 08:26:23 EDT
Created attachment 1087234 [details]
File: backtrace
Comment 2 Matthias Scholz 2015-10-28 08:26:25 EDT
Created attachment 1087235 [details]
File: cgroup
Comment 3 Matthias Scholz 2015-10-28 08:26:27 EDT
Created attachment 1087236 [details]
File: core_backtrace
Comment 4 Matthias Scholz 2015-10-28 08:26:29 EDT
Created attachment 1087237 [details]
File: dso_list
Comment 5 Matthias Scholz 2015-10-28 08:26:31 EDT
Created attachment 1087238 [details]
File: environ
Comment 6 Matthias Scholz 2015-10-28 08:26:32 EDT
Created attachment 1087239 [details]
File: limits
Comment 7 Matthias Scholz 2015-10-28 08:26:34 EDT
Created attachment 1087240 [details]
File: maps
Comment 8 Matthias Scholz 2015-10-28 08:26:36 EDT
Created attachment 1087241 [details]
File: mountinfo
Comment 9 Matthias Scholz 2015-10-28 08:26:37 EDT
Created attachment 1087242 [details]
File: namespaces
Comment 10 Matthias Scholz 2015-10-28 08:26:39 EDT
Created attachment 1087243 [details]
File: open_fds
Comment 11 Matthias Scholz 2015-10-28 08:26:41 EDT
Created attachment 1087244 [details]
File: proc_pid_status
Comment 12 Matthias Scholz 2015-10-28 08:26:42 EDT
Created attachment 1087245 [details]
File: var_log_messages
Comment 13 Matt Wheeler 2015-10-28 13:30:35 EDT
Another user experienced a similar problem:

Trying to run ls in gvfs dir

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        zsh
crash_function: charrefinc
executable:     /usr/bin/zsh
global_pid:     5047
kernel:         4.2.3-200.fc22.x86_64
package:        zsh-5.0.8-5.fc22
reason:         zsh killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 14 Kamil Dudka 2015-10-29 05:09:08 EDT
(In reply to Matthias Scholz from comment #0)
> Potential duplicate: bug 1245116

According to the bakctrace it is the same issue, already reported upstream:

http://www.zsh.org/mla/workers/2015/msg01769.html

(In reply to Matt Wheeler from comment #13)
> Trying to run ls in gvfs dir

How can one access a gvfs dir with zsh?

Please provide a sequence of commands to run.
Comment 15 Kamil Dudka 2015-11-20 06:30:09 EST

*** This bug has been marked as a duplicate of bug 1245116 ***
Comment 16 Matt Wheeler 2015-12-07 14:20:10 EST
The sequence of steps is:

Open SMB share using Nautilus
Right click in share in Nautilus -> Open in Terminal

Unfortunately I can't remember what else I was doing to trigger the crash...

I sent this reply by email but apparently redhat bugzilla can't cope with email bug comments.

Note You need to log in before you can comment on or make changes to this bug.