Bug 1276031 - Assertion failure while moving files between directories on a dispersed volume
Assertion failure while moving files between directories on a dispersed volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Xavi Hernandez
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 08:57 EDT by Xavi Hernandez
Modified: 2016-06-16 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavi Hernandez 2015-10-28 08:57:28 EDT
Description of problem:

Mount log shows assertion failures and the mount point remains inaccessible when moving files between directories.

Version-Release number of selected component (if applicable): mainline


How reproducible:

Always

Steps to Reproduce:
1. touch test
2. mkdir dir
3. mv test dir/

Actual results:

Operation fails

Expected results:

File moved to directory 'dir'

Additional info:
Comment 1 Vijay Bellur 2015-10-28 09:07:08 EDT
REVIEW: http://review.gluster.org/12445 (cluster/ec: Fix bad management of lock owners) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 2 Niels de Vos 2016-06-16 09:41:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.