Bug 127604 - Invalid partition table accepted by Disk Druid
Invalid partition table accepted by Disk Druid
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-10 14:56 EDT by Reshat Sabiq
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reshat Sabiq 2004-07-10 14:56:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Logical /boot partition is not acceptable for GRUB. However, Disk
Druid accepts such a set up when it is pre-partitioned, an the only
thing done during installation is choosing which partition does what.
I believe Disk Druid needs an enhancement (to fix what can be called a
bug): if the user specifies GRUB as bootloader and /boot is not
primary, this should be descriptively reported back to the user. The
code to check this is already there, because this gets prevented while
partitioning Linux setup entirely in Disk Druid, but if partitioning
has been done in advance (such as w/ fdisk), Disk Druid lets it pass.
The fix would probably be trivial, such as calling an existing method,
getting a false return value, and not accepting user's selection of
/boot partition when it's logical, and GRUB is the loader chosen.

P.S. Pre-partitioning appears to be a relatively common thing to do.
And yes, i will never forget the lesson learnt, but i wish i didn't
spend that much time on learning it. :)
Fixing this would save time to many other folks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from a rescue CD
2. Partition the disk to be used for Linux install, providing a /boot
partition that is logical (i used fdisk)
3. Boot from Fedora install CD
4. Choose GRUB as loader, and the previously made logical partition as
/boot
5. Finish installing (installing GRUB into /boot): message is given
that install is successful.
6. Boot (if necessary first change a flag on the /boot partition in
step 2)


Actual Results:  Invalid partition table (and failure to boot into Linux)

Expected Results:  Successful boot into GRUB OS selection, or straight
into FC (2).

Additional info:

I encountered this in a dual-boot setup, and this is more likely to
happen for dual-boot systems, but it is just as well applicable to
single boot setups.
At the very least, it would be useful to have it in a QA, because i'm
sure not everybody knows that logical /boot and GRUB don't work together.
Comment 1 Jeremy Katz 2004-10-07 14:56:44 EDT
Unfortunately, some BIOSes will allow this and it's not possible to
tell those that can vs those that can't.
Comment 2 Reshat Sabiq 2004-10-07 23:13:06 EDT
Well, if some BIOSes can work with logical /boot partition and GRUB,
and apparently many or most can't, then the least we can do is add
this information to the Q&A. I think it would be a good policy
overall. My goal is to save people time, because i am not a big fan of
spending time  on issues like this, and learning it all on my own. If
such cases are listed in QA, a lot of efficiencies will be realized
across the community.

Note You need to log in before you can comment on or make changes to this bug.