Bug 1276057 - ISCSI operations fail with python-rtslib-2.1.fb57-2.el7.noarch
ISCSI operations fail with python-rtslib-2.1.fb57-2.el7.noarch
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 5.0 (RHEL 7)
Assigned To: Eric Harney
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 10:30 EDT by Matthew Booth
Modified: 2016-04-27 01:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1.5-2.el6ost, openstack-cinder-2014.1.5-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 09:25:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 111260 None None None Never

  None (edit)
Description Matthew Booth 2015-10-28 10:30:18 EDT
Description of problem:
The new version of python-rtslib adds a broken implementation of CFSNode.__eq__ which doesn't check the type of other. This breaks add_initiator, and probably other things, in cinder-rtstool when it does 'if target == None'.

Version-Release number of selected component (if applicable):
openstack-cinder-2014.1.5-1.el7ost.noarch
Comment 2 Matthew Booth 2015-10-28 10:34:21 EDT
Broken rtslib is python-rtslib-2.1.fb57-2.el7.noarch
Comment 3 Matthew Booth 2015-10-28 10:36:51 EDT
python-rtslib bug is bug 1276044
Comment 4 Matthew Booth 2015-10-30 06:31:03 EDT
For info, the python-rtslib maintainer has already pushed an updated package which fixes this problem.

I've submitted the cinder patch to the repo. I'm happy to build it once it gets acks.
Comment 8 errata-xmlrpc 2015-12-22 09:25:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2689.html

Note You need to log in before you can comment on or make changes to this bug.