Bug 1276068 - Unable to bootstrap
Unable to bootstrap
Status: CLOSED DUPLICATE of bug 1268883
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 11:11 EDT by Marcus Moeller
Modified: 2015-10-29 07:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 07:30:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2015-10-28 11:11:00 EDT
Description of problem:
I am trying to bootstrap a system using the following command:

dnf -y --nogpgcheck  --installroot=/path/to/my/f23 --releasever=23 --nogpgcheck --disablerepo='*' --enablerepo=fedora --enablerepo=updates  groupinstall Core

on a Fedora 23 Beta host.

This results in a lot of errors like: 

warning: %posttrans(...) scriptlet failed, exit status 126 

starting with glibc and the following packages not to be installed in consequence:

Failed:
 avahi-autoipd.x86_64 0.6.31-43.fc23
 ca-certificates.noarch 2015.2.5-1.0.fc23 
 coreutils.x86_64 8.24-4.fc23 
 dbus.x86_64 1:1.10.0-1.fc23
 initscripts.x86_64 9.64-1.fc23
 libutempter.x86_64 1.1.6-7.fc23                  
 man-db.x86_64 2.7.1-10.fc23
 openssh.x86_64 7.1p1-3.fc23
 openssh-server.x86_64 7.1p1-3.fc23
 pinentry.x86_64 0.9.6-3.fc23
 ppp.x86_64 2.4.7-8.fc23
 selinux-policy-targeted.noarch 3.13.1-152.fc23   
 systemd.x86_64 222-7.fc23 
 trousers.x86_64 0.3.13-5.fc23              

which leads to an unusable system. Same works on a Fedora 22 host. I have already tried to downgrade dnf to the version found in Fedora 22 without a luck. It also does not seem to be releated to dnf directly but to rpm.

Version-Release number of selected component (if applicable):
dnf is 1.1.3-1 rpm is rpm-4.13.0

How reproducible:
Use Fedora 23 Beta live (I tried the server edition)
Run:
dnf -y --nogpgcheck  --installroot=/path/to/my/f23 --releasever=23 --nogpgcheck --disablerepo='*' --enablerepo=fedora --enablerepo=updates  groupinstall Core

Actual results:
Bootstrap does not finish due to errors that occur during package installation (post)

Expected results:
Bootstrap should work as expected
Comment 1 Ľuboš Kardoš 2015-10-29 07:30:43 EDT
The bug for this already exists and it should be fixed in rpm-4.13.0-0.rc1.4.fc23.

*** This bug has been marked as a duplicate of bug 1268883 ***

Note You need to log in before you can comment on or make changes to this bug.