Bug 1276073 - Cannot connect to WPA2 Enterprise network
Cannot connect to WPA2 Enterprise network
Status: CLOSED DUPLICATE of bug 1154200
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 11:20 EDT by Gergo
Modified: 2016-04-04 13:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 13:11:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of journalctl, wpa_supplicant.log and dmesg (116.94 KB, text/plain)
2015-10-28 11:20 EDT, Gergo
no flags Details
trying to connect with wpa_supplicant (1.92 KB, text/plain)
2015-11-05 18:04 EST, Gergo
no flags Details

  None (edit)
Description Gergo 2015-10-28 11:20:24 EDT
Created attachment 1087260 [details]
output of journalctl, wpa_supplicant.log and dmesg

Description of problem:
When trying to connect to a WPA2 Enterprise network, after hitting connect it tries to connect but eventually it stops and nothing happens.
The bug is present in Fedora 22 and 23 too. 
(On Ubuntu 15.10 I can connect to the network using the same computer.)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Select desired wireless network from list.
2. Fill in the credentials.
3. Hit the button to connect.

Actual results:
After saying 'connecting' for a short time (1-2 minutes) it stops. 

Expected results:
Should be able to establish connection with the network.

Additional info:
Network SSID to look for in the attached logs is 'UPC Wi-Free'.

I've seen in an other bug report to downgrade wpa_supplicant but nothing changed with the older version for me.
Comment 1 Gergo 2015-11-05 18:01:29 EST
I disabled NetworkManager.service and tried to connect with commandline wpa_supplicant. It didn't connect, just hang at the last line. See attachment.

Also I booted up centos7 live and succesfully connected to this network.

Name        : wpa_supplicant
Arch        : x86_64
Epoch       : 1
Version     : 2.0
Release     : 13.el7_0


Name        : NetworkManager
Arch        : x86_64
Epoch       : 1
Version     : 1.0.0
Release     : 14.git20150121.b4ea599c.el7


centos7 gnome live
3.10.0-229.el7.x86_64
Comment 2 Gergo 2015-11-05 18:04 EST
Created attachment 1090420 [details]
trying to connect with wpa_supplicant

with disabled NetworkManager, trying to connect through commandline wpa_supplicant
Comment 3 Matan Ziv-Av 2015-11-16 13:06:51 EST
I have the same problem after upgrading to Fedora 23.

Using F22 wpa_supplicant with F22 openssl-libs (1.0.1k-12) does connect.

Using F22 wpa_supplicant with F23 openssl-libs (1.0.2d-2) does not connect (authentication failed).

I did not try F23 wpa_supplicant with F22 openssl-libs, since it requires at least openssl-1.0.2. But wpa_supplicant has the exact same version, so I suspect openssl.
Comment 4 Gergo 2016-04-04 13:11:58 EDT
I found out this is a known issue since Fedora 21. Not a bug though.

*** This bug has been marked as a duplicate of bug 1154200 ***

Note You need to log in before you can comment on or make changes to this bug.