Bug 1276078 - RHEL7 ksvalidator command map for RHEL6 validation missing the 'key' command
RHEL7 ksvalidator command map for RHEL6 validation missing the 'key' command
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pykickstart (Show other bugs)
7.1
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 11:49 EDT by Jon McKenzie
Modified: 2016-11-03 20:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: pykickstart-1.99.66.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:11:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon McKenzie 2015-10-28 11:49:09 EDT
Description of problem:

The 'ksvalidator utility, when run using the RHEL6 version (e.g. 'ksvalidator -v RHEL6') throws an error when the 'key' kickstart command is present. This differs from the behavior of 'ksvalidator' in RHEL6, which does not error on this command.

Version-Release number of selected component (if applicable):

For RHEL7:  pykickstart-1.99.43.17-1.el7.noarch
Comparing to RHEL6 version: pykickstart-1.74.20-1.el6.noarch

How reproducible:

Consistently.

Steps to Reproduce:
1. Create a RHEL6 kickstart file using the 'key' command in the kickstart header (e.g. 'key --skip')
2. Execute 'ksvalidator -v RHEL6 /path/to/kickstart-file.cfg'

Actual results:

An error is thrown, e.g.

The following problem occurred on line 8 of the kickstart file:

Unknown command: key


Expected results:

No errors are thrown (similar to the behavior in RHEL6).
Comment 2 Chris Lumens 2016-01-27 13:22:42 EST
Just needs a cherry-pick of 142c9b021f60ff00d63e855cd02dc951ee96c8f0.
Comment 3 Chris Lumens 2016-01-27 14:09:05 EST
Whoops, I should have run tests before pushing.  This actually needs a cherry-pick of c6252828993b9c34e4fac123196605c368fa0601.
Comment 5 Michal Kovarik 2016-07-26 10:01:10 EDT
Verified on pykickstart-1.99.66.9-1.el7.noarch, 'key' command is accepted for RHEL6.
Comment 7 errata-xmlrpc 2016-11-03 20:11:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2184.html

Note You need to log in before you can comment on or make changes to this bug.