Bug 127608 - incorrect error message in case of package conflict
incorrect error message in case of package conflict
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: 124619
  Show dependency treegraph
 
Reported: 2004-07-10 17:01 EDT by Ian Collier
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 16:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Collier 2004-07-10 17:01:34 EDT
Description of problem:
OK, as we all know by now, the recent ppp update conflicts with
initscripts-7.53-1.  This bug report isn't about that conflict
per se.  However, the error message which up2date produces is
plain wrong.

Version-Release number of selected component (if applicable):
up2date-4.3.19-1

How reproducible:
Always (until ppp updated by hand)

Steps to Reproduce:
1. up2date --nox -u
  
Actual results: (the following are the last few lines of output)
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
initscripts-7.53-1                       requires pppd < 2.3.9

Expected results:
initscripts *conflicts with* pppd < 2.3.9 - which is the exact
opposite of what the above message says.

Additional info:
Obviously the interactive graphical version also produces this
message.
Comment 1 Matthew Miller 2005-04-26 12:12:08 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 2 John Thacker 2006-04-24 16:29:50 EDT
Closing due to lack of response by reporter.
Also, up2date is deprecated and removed from Fedora Core in the latest
version.  This is not a security issue, so it's not going to get fixed.
(It could be filed for RHEL if it shows up there.)

Note You need to log in before you can comment on or make changes to this bug.