Bug 1276085 - [anaconda] AttributeError: 'gi.repository.BlockDev' object has no attribute 'plugin_specs-from_names'
Summary: [anaconda] AttributeError: 'gi.repository.BlockDev' object has no attribute '...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-28 16:21 UTC by Joachim Frieben
Modified: 2015-10-29 15:24 UTC (History)
7 users (show)

Fixed In Version: python-blivet-1.16-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-29 15:24:12 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of anaconda with the backtrace related to the crash (132.46 KB, image/png)
2015-10-28 16:21 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2015-10-28 16:21:30 UTC
Created attachment 1087278 [details]
Screenshot of anaconda with the backtrace related to the crash

Description of problem:
After booting from current network install image boot.iso, anaconda crashes and issues a backtrace ending with:

    "AttributeError: 'gi.repository.BlockDev' object has no attribute 'plugin_specs-from_names'" .

Version-Release number of selected component (if applicable):
anaconda-24.4-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Boot from current boot.iso in gnome-boxes.

Actual results:
Anaconda crashes after start-up.

Expected results:
Anaconda starts up correctly and launches the graphical installer.

Additional info:
None

Comment 1 David Shea 2015-10-28 17:14:00 UTC
Please attach the logs from /tmp as individual, text/plain attachments.

What I suspect happened is that the boot.iso was built with libblockdev-1.3, which moves the python gi overrides into a separate package, but that it does not have the new python-blivet that pulls in the separate package as a dependency.

Comment 2 Adam Williamson 2015-10-28 17:28:34 UTC
It looks like the new libblockdev landed yesterday:

http://koji.fedoraproject.org/koji/buildinfo?buildID=694432

but there's been no new python-blivet, the last Rawhide build of python-blivet was python-blivet-1.15-2.fc24 on 2015-10-06.

This broke all Rawhide tests (and Cloud images, as they're built through anaconda) for today's nightly. It crashes early enough that the crash handler doesn't kick in so I don't have any useful logs from openQA, but if we want to be double-plus-sure I could grab an image and reproduce manually, it seems very likely it just needs a new python-blivet, though.

Comment 3 Joachim Frieben 2015-10-28 21:18:41 UTC
(In reply to David Shea from comment #1)
There are no anaconda log files in /tmp yet when the crash occurs. There is only /tmp/syslog which, however, does not reveal any related entry.


Note You need to log in before you can comment on or make changes to this bug.