Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1276087 - "ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly" found in appliance after installing vmware-vix-disk
Summary: "ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.6.0
Assignee: Rich Oliveri
QA Contact: Ramesh A
URL:
Whiteboard:
Depends On:
Blocks: 1290395
TreeView+ depends on / blocked
 
Reported: 2015-10-28 16:36 UTC by Ramesh A
Modified: 2016-08-18 05:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1290395 (view as bug list)
Environment:
Last Closed: 2016-01-19 19:44:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
rananda: automate_bug-


Attachments (Terms of Use)
evm.log (81.47 KB, text/plain)
2015-10-28 16:36 UTC, Ramesh A
no flags Details
SSA-ERROR.png (82.35 KB, image/png)
2015-10-28 16:44 UTC, Ramesh A
no flags Details

Description Ramesh A 2015-10-28 16:36:35 UTC
Created attachment 1087280 [details]
evm.log

Description of problem:
After installing the vmware-vix-disklib (VDDK), following error is found in the production.log and evm.log file

"ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly"

Version-Release number of selected component (if applicable):
5.5.0.7-beta1.3.20151021133253_ed40d96

How reproducible:
100%

Steps to Reproduce:
1. Deploy the appliance and configure the database
2. Install the VDDK (VMware-vix-disklib-5.5.3-1909144.x86_64.tar.gz) and reboot the virtual machine (reboot command)
3. After the virtual machine is rebooted, check the evm.log and production.log file

Actual results:
Following error is thrown in the production.log file 
"ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly"

For more info refer the below mentioned production.log and attached evm.log file

Expected results:
Should not throw any error message

Additional info:
evm.log file is in the attachment

production.log:
===============
[----] E, [2015-10-28T11:54:16.564163 #2926:12bb988] ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:16.603176 #2926:12bb988] ERROR -- : PG::UnableToSend: socket not open
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqPriorityWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:16.707443 #2745:f0198c] ERROR -- : PG::AdminShutdown: FATAL:  terminating connection due to administrator command
server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:16.900898 #2929:b0d998] ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:16.918583 #2917:bfb990] ERROR -- : PG::ConnectionBad: PQconsumeInput() server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:16.958580 #2929:b0d998] ERROR -- : PG::UnableToSend: socket not open
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqPriorityWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:16.978742 #2932:cbd98c] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:17.062653 #2920:9b198c] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:17.120961 #2917:bfb990] ERROR -- : PG::UnableToSend: socket not open
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqEventHandler') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:17.204679 #2923:10e7990] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:17.377391 #2920:9b198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqGenericWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:17.419364 #2923:10e7990] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqGenericWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:17.700010 #2932:cbd98c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqReportingWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:17.936061 #2961:459994] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:18.857123 #2935:10bb994] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:18.925039 #2959:6c5994] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT pg_backend_pid()
[----] E, [2015-10-28T11:54:19.141696 #2961:459994] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqAutomateWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:19.377186 #2935:10bb994] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqReportingWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:20.247307 #2938:d19994] ERROR -- : PG::UnableToSend: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
: SELECT  "miq_queue".* FROM "miq_queue" WHERE "miq_queue"."queue_name" = $1 AND "miq_queue"."state" = $2 AND "miq_queue"."zone" = $3 AND "miq_queue"."priority" = $4 AND "miq_queue"."class_name" = $5 AND "miq_queue"."method_name" = $6 AND "miq_queue"."server_guid" = $7  ORDER BY priority, id LIMIT 1
[----] E, [2015-10-28T11:54:20.508457 #2938:d19994] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqScheduleWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:20.759650 #2959:6c5994] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_workers".* FROM "miq_workers" WHERE "miq_workers"."type" IN ('MiqAutomateWorker') AND "miq_workers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:21.880052 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:26.886918 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:31.903854 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:36.930305 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:41.935202 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_servers".* FROM "miq_servers" WHERE "miq_servers"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:46.946570 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:51.950324 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:56.954632 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "zones".* FROM "zones" WHERE "zones"."id" = $1 LIMIT 1
[----] E, [2015-10-28T11:54:58.432913 #2745:f0198c] ERROR -- : PG::UnableToSend: no connection to the server
: SELECT  "miq_servers".* FROM "miq_servers" WHERE "miq_servers"."guid" = $1 LIMIT 1

Comment 3 Ramesh A 2015-10-28 16:44:24 UTC
Created attachment 1087281 [details]
SSA-ERROR.png

Comment 6 Dave Johnson 2015-10-30 21:54:35 UTC
Thom, can you try to retest this and work it into some of your SSA testing please, thx!

Comment 7 Dave Johnson 2015-10-30 21:56:15 UTC
After reading Rich's comment, dropping needinfo on Thom  :)  ...apologies for the spam, see if you can reproduce this Ramesh.

Comment 8 Ramesh A 2015-11-02 17:07:52 UTC
Hi Rich,

I am not able to reproduce this in the latest build 5.5.0.8-beta1.4.20151027164951_4ab7fea.

Hence can be closed

Thanks,
Ramesh

Comment 9 Rich Oliveri 2016-01-19 19:44:32 UTC
As per https://bugzilla.redhat.com/show_bug.cgi?id=1276087#c8 Cannot be reproduced.


Note You need to log in before you can comment on or make changes to this bug.