This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276091 - overcloud deployment fails when applying /var/lib/heat-config/heat-config-puppet/7737c5f1-9149-40b0-95ac-932cd607ba29.pp
overcloud deployment fails when applying /var/lib/heat-config/heat-config-pup...
Status: CLOSED DUPLICATE of bug 1275812
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 7.0 (Kilo)
Assigned To: Jay Dobies
yeylon@redhat.com
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 13:01 EDT by Steve Linabery
Modified: 2016-04-26 19:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 13:42:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 180566 None None None Never

  None (edit)
Description Steve Linabery 2015-10-28 13:01:47 EDT
Description of problem:
In recent poodle CI after fix for bz#1274439 landed in the poodle, the overcloud deployment fails with an error when applying the puppet template in $subj

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

[root@overcloud-controller-0 heat]# journalctl -u os-collect-config | grep ERROR
Oct 27 18:41:43 overcloud-controller-0.localdomain os-collect-config[4332]: [2015-10-27 18:41:43,569] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/7737c5f1-9149-40b0-95ac-932cd607ba29.pp. [1]
[root@overcloud-controller-0 heat]# grep heat_domain_create /var/lib/heat-config/heat-config-puppet/7737c5f1-9149-40b0-95ac-932cd607ba29.pp
  Class['::keystone::roles::admin'] -> Exec['heat_domain_create']

My guesss is whatever generates that template also needs to be using Keystone_domain instead of heat_domain_create.
Comment 2 Ronelle Landy 2015-10-28 13:08:46 EDT
rpm info:

[stack@instack ~]$ rpm -qa | grep openstack
openstack-ceilometer-alarm-2015.1.1-1.el7ost.noarch
python-django-openstack-auth-1.2.0-5.el7ost.noarch
openstack-keystone-2015.1.1-1.el7ost.noarch
python-openstackclient-1.0.3-3.el7ost.noarch
openstack-ceilometer-collector-2015.1.1-1.el7ost.noarch
openstack-tuskar-0.4.18-5.el7ost.noarch
openstack-nova-novncproxy-2015.1.1-3.el7ost.noarch
openstack-swift-object-2.3.0-2.el7ost.noarch
openstack-tuskar-ui-extras-0.0.4-2.el7ost.noarch
openstack-glance-2015.1.1-3.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-3.git49b57eb.el7ost.noarch
openstack-heat-api-2015.1.1-6.el7ost.noarch
openstack-ceilometer-central-2015.1.1-1.el7ost.noarch
openstack-neutron-openvswitch-2015.1.1-13.el7ost.noarch
openstack-nova-api-2015.1.1-3.el7ost.noarch
openstack-dashboard-2015.1.1-4.el7ost.noarch
openstack-heat-common-2015.1.1-6.el7ost.noarch
openstack-selinux-0.6.37-1.el7ost.noarch
openstack-tempest-kilo-20150708.2.el7ost.noarch
redhat-access-plugin-openstack-7.0.0-0.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-nova-console-2015.1.1-3.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch
openstack-neutron-2015.1.1-13.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch
openstack-heat-engine-2015.1.1-6.el7ost.noarch
openstack-ironic-discoverd-1.1.0-8.el7ost.noarch
openstack-puppet-modules-2015.1.8-26.el7ost.noarch
openstack-nova-conductor-2015.1.1-3.el7ost.noarch
openstack-swift-account-2.3.0-2.el7ost.noarch
openstack-swift-proxy-2.3.0-2.el7ost.noarch
openstack-ceilometer-common-2015.1.1-1.el7ost.noarch
openstack-heat-api-cfn-2015.1.1-6.el7ost.noarch
openstack-ceilometer-api-2015.1.1-1.el7ost.noarch
openstack-ironic-api-2015.1.1-5.el7ost.noarch
openstack-swift-plugin-swift3-1.7-3.el7ost.noarch
openstack-tuskar-ui-0.4.0-5.el7ost.noarch
openstack-utils-2014.2-1.el7ost.noarch
openstack-heat-api-cloudwatch-2015.1.1-6.el7ost.noarch
openstack-ceilometer-notification-2015.1.1-1.el7ost.noarch
openstack-nova-compute-2015.1.1-3.el7ost.noarch
openstack-neutron-ml2-2015.1.1-13.el7ost.noarch
openstack-nova-scheduler-2015.1.1-3.el7ost.noarch
openstack-dashboard-theme-2015.1.1-4.el7ost.noarch
openstack-nova-cert-2015.1.1-3.el7ost.noarch
openstack-ironic-conductor-2015.1.1-5.el7ost.noarch
openstack-swift-container-2.3.0-2.el7ost.noarch
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch
openstack-nova-common-2015.1.1-3.el7ost.noarch
openstack-neutron-common-2015.1.1-13.el7ost.noarch
openstack-ironic-common-2015.1.1-5.el7ost.noarch
openstack-swift-2.3.0-2.el7ost.noarch

python-rdomanager-oscplugin-0.0.10-10.el7ost.noarch

[stack@instack ~]$ rpm -qa | grep instack
instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-32.el7ost.noarch
Comment 4 Steve Baker 2015-10-28 18:32:27 EDT
openstack-tripleo-heat-templates will need a change like this [1] in puppet/manifests/overcloud_controller.pp and puppet/manifests/overcloud_controller_pacemaker.pp

https://review.gerrithub.io/#/c/244988/1/elements/puppet-stack-config/puppet-stack-config.pp
Comment 5 Steve Baker 2015-10-29 01:25:25 EDT
The upstream heat domain feature hasn't landed yet (see attached gerrit change), and does the right thing.

Maybe Jiri would be best to fix this downstream.
Comment 6 James Slagle 2015-11-02 13:42:32 EST

*** This bug has been marked as a duplicate of bug 1275812 ***

Note You need to log in before you can comment on or make changes to this bug.