Bug 1276093 - DNF is getting very slow on rawhide
DNF is getting very slow on rawhide
Status: CLOSED DUPLICATE of bug 850896
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 13:11 EDT by Zdenek Kabelac
Modified: 2015-11-02 10:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:28:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2015-10-28 13:11:52 EDT
Description of problem:

The whole idea of downloading  DB files to speed-up deps resolving/upgrading probably missed it's main goal. Since those DB files are getting absurdly big
(It's like over 80MB of downloaded  junk - were just few things in reality has changed)

When I want to install simple small package file like some 200KB lib-dev it's getting ridiculous I've to wait even minutes before it actually start to download requested package.

I guess -  we should introduce  '2G Tuesdays' like  Facebook people have - so someone would design actually something usable - current  logic to download tens of MB of DB data to upgrade single package  doesn't scale...

And downloading these  multi-MB files many times per day to be ready when executing  'dnf install' - is NOT a solution!

Version-Release number of selected component (if applicable):
dnf-1.1.3-1.fc24.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michal Luscon 2015-11-02 10:28:09 EST

*** This bug has been marked as a duplicate of bug 850896 ***

Note You need to log in before you can comment on or make changes to this bug.