Bug 1276103 - Deleting a single schedule displays message as - "The selected Report Schedules was deleted" instead of schedule name
Deleting a single schedule displays message as - "The selected Report Schedul...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity low
: GA
: 5.6.0
Assigned To: Dávid Halász
Ramesh A
ui:schedule
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 13:48 EDT by Ramesh A
Modified: 2016-06-29 11:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:01:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
delete flash message (63.55 KB, image/png)
2015-10-28 13:48 EDT, Ramesh A
no flags Details

  None (edit)
Description Ramesh A 2015-10-28 13:48:29 EDT
Created attachment 1087299 [details]
delete flash message

Description of problem:
Deleting a single schedule displays message as - "The selected Report Schedules was deleted" instead of schedule name

Version-Release number of selected component (if applicable):
5.5.0.7-beta1.3.20151021133253_ed40d96

How reproducible:
100%

Steps to Reproduce:
1. Navigate to cloud intelligence ==> Reports ==> Schedules ==> click on any schedule
2. Click on any schedule ==> Configuration ==> Delete this Schedule from the database
3. Observe the flash message

Actual results:
Displays flash message as "The selected Report Schedules was deleted" instead of schedule name.  Refer the screenshot for further details 

Expected results:
Should display flash message stating the "Schedule <name> was deleted"

Additional info:
Comment 7 CFME Bot 2016-05-31 14:21:01 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2b0ade56e6f8b97f178fe8b8e556504297150435

commit 2b0ade56e6f8b97f178fe8b8e556504297150435
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Tue May 31 12:41:03 2016 +0200
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Tue May 31 13:01:28 2016 +0200

    Changed flash messages for report schedule deletion
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276103

 app/controllers/report_controller/schedules.rb     | 15 ++++-----
 .../miq_report_controller/schedules_spec.rb        | 37 ++++++++++++++++++++++
 2 files changed, 44 insertions(+), 8 deletions(-)
 create mode 100644 spec/controllers/miq_report_controller/schedules_spec.rb
Comment 8 Ramesh A 2016-06-07 06:41:23 EDT
Good to go.  Verified and working fine in 5.6.0.9-rc2.20160531154046_b4e2f6d
Comment 11 errata-xmlrpc 2016-06-29 11:01:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.