Bug 1276110 - Firefox doesn't play videos in google+
Summary: Firefox doesn't play videos in google+
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-28 18:24 UTC by Eduardo Silva
Modified: 2016-05-12 10:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-12 10:34:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Eduardo Silva 2015-10-28 18:24:18 UTC
Description of problem:
Firefox doesn't play videos hosted on youtube within google+ interface.

Version-Release number of selected component (if applicable):
Firefox 41.0.2

How reproducible:
Allways

Steps to Reproduce:
1. An example, go to https://plus.google.com/109637860626261571611/posts/DnGCTXw5RRS?pid=6209230762541382930&oid=104349425299854550670

Actual results:
Some screens from video are shown, the video stops. Trying to play shows "An error ocurred. Please try again later".
This happens with all videos inside google+.

Comment 1 Jan Horak 2015-10-29 08:33:03 UTC
This works for me. Please try a fresh profile and in case if it is working please check if you have  any of these settings changed: 
http://forum.pinguyos.com/Thread-Enable-Hardware-Acceleration-in-Firefox-Get-1080p-in-Youtube%E2%80%99s-HTML5-player

Comment 2 Martin Stransky 2015-10-29 09:36:43 UTC
Also please test in safe mode ($firefox -safe-mode)

Comment 3 Eduardo Silva 2015-10-29 16:55:24 UTC
I tried both --safe-mode and a new profile, and the linked video above still doesn't play. Here's youtube player debug information:

{"cpn":"g8eg6_w4-Aj4tiRA","vct":"0.000","vd":"NaN","vpl":"","vbu":"","vpa":true,"vsk":false,"ven":false,"vpr":1,"vrs":0,"vns":0,"vec":null,"vvol":0.97,"state":"80","debug_error":{"errorCode":"api.invalidparam","errorDetail":null,"message":"Ocorreu um erro. Tente novamente mais tarde.","messageKey":"YTP_ERROR_GENERIC_WITHOUT_LINK"},"debug_videoId":null,"cgr":true,"debug_playbackQuality":"unknown","debug_date":"Thu Oct 29 2015 16:51:02 GMT+0000 (WET)"}

Comment 4 Martin Stransky 2015-10-30 13:49:55 UTC
Well, I can reproduce that. I can't also play that with upstream Mozilla binary.

Comment 5 Martin Stransky 2016-05-12 10:34:08 UTC
Please make sure you have ffmpeg-libs installed. Firefox removed support of gstreamer and moved do ffmpeg.


Note You need to log in before you can comment on or make changes to this bug.