This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127612 - Nautilus does not refresh directories which are symlinks properly
Nautilus does not refresh directories which are symlinks properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-10 18:44 EDT by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 14:41:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2004-07-10 18:44:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040620

Description of problem:
If I navigate to a directory which is a symlink to another, I can't
see updates to that directory without clicking refresh (when that
exists, because it doesn't exist in spatial mode).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a directory "foo" in your home directory
2.make a symlink to it on the desktop
3.go with nautilus to "foo" using the symlink
4.go with nautilus to "foo" directly (open location or navigating from
"home")
5.open an xterm
6.cd foo; touch bar

    

Actual Results:  After step 6, one sees that window 4. shows "bar"
immediately and 3. does not.


Expected Results:  Both windows should show "bar" immediately.

Additional info:

This also happens when, for instance, clicking a tar.gz in "foo" and
doing "extract here". The files/folders created by file-roller do not
show up until a refresh is done.
Comment 1 Carlos Rodrigues 2004-07-10 18:47:25 EDT
BTW: there is no problem with subdirectories of the symlinked
directory, only with the symlink itself.
Comment 2 Alexander Larsson 2004-10-05 09:11:52 EDT
Hmm. We're monitoring both directories with. I think this is an actual
bug in gamin. It should probably follow the folder symlink when its
being monitored.
Comment 3 Daniel Veillard 2004-10-05 09:27:48 EDT
To some extent, okay. But I won't be able to catch if the symlink
is changed to point to something else.

Daniel
Comment 4 Frédéric Marchand 2005-03-02 04:58:43 EST
I confirm this bug with Fam too
Comment 5 Carlos Rodrigues 2005-03-02 09:48:58 EST
The lastest gamin errata in FC3 seems to fix this.

Note You need to log in before you can comment on or make changes to this bug.