Bug 1276153 - ipa-client-automount --uninstall removes sss entirely from /etc/nssswitch.conf
ipa-client-automount --uninstall removes sss entirely from /etc/nssswitch.conf
Status: CLOSED DUPLICATE of bug 1141799
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 17:50 EDT by prasun.gera
Modified: 2015-11-05 08:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 08:55:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description prasun.gera 2015-10-28 17:50:38 EDT
Description of problem:
Uninstalling automount removes sss from nssswitch.conf whereas it should be only touching the automount line. I suspect it is doing backup/restore at a very coarse granularity, and possibly restoring it to a time before the ipa client was installed (instead of the time before automount was setup )

Version-Release number of selected component (if applicable):

ipa-client-3.0.0-47.el6.x86_64

How reproducible:
Not easily. I've seen it a few times on some systems. 

Steps to Reproduce:
1. ipa-client-automount --uninstall

Actual results:

sss is purged entirely from nssswitch.conf

Expected results:

sss should be removed only from the automount line

Additional info:
Comment 2 Petr Vobornik 2015-10-29 07:38:38 EDT
Confirming. On FreeIPA 4.2 

 $ ipa-client-install
 $ ipa-client-automount
 $ ipa-client-automount --uninstall

Returns nsswitch.conf to a state before ipa-client-install

This doesn't mean that all sss is removed but that the restoration of backup files doesn't work well.

The reason is that(at least on 4.2) ipa-client-automount shares backup state with ipa-client-install. It doesn't touch nsswith.conf on installation(no new backup) but on --uninstall it restores nsswith.conf.
Comment 3 Petr Vobornik 2015-10-29 07:39:57 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5415
Comment 4 Petr Vobornik 2015-11-05 08:55:15 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1141799#c7

*** This bug has been marked as a duplicate of bug 1141799 ***

Note You need to log in before you can comment on or make changes to this bug.