Bug 1276165 - F22 release notes still in F23
F22 release notes still in F23
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release-notes (Show other bugs)
23
All All
unspecified Severity high
: ---
: ---
Assigned To: John J. McDonough
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-10-28 20:14 EDT by Adam Williamson
Modified: 2015-11-02 18:13 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 18:13:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-10-28 20:14:23 EDT
The fedora-release-notes package in F23 is still for F22:

fedora-release-notes-22.01-1.fc22.noarch

"This document provides the release notes for Fedora 22..."

it is included in all live images except, I think, Workstation (because it's part of the @standard group, which is in fedora-live-base.ks). So the KDE, Xfce etc etc lives have a menu entry which shows you the Fedora 22 release notes.

This is a clear violation of "The final branded release notes must be present on release-blocking images and the appropriately versioned generic release notes must be available in the release repository.", which somehow no-one thought to check until now. Le sigh.

https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Release_notes
Comment 1 Adam Williamson 2015-10-28 20:16:44 EDT
We have an update:

https://bodhi.fedoraproject.org/updates/FEDORA-2015-e6b55c54f7

it just never got pulled into any composes.
Comment 2 Dennis Gilmore 2015-10-28 21:59:43 EDT
+1 blocker
Comment 3 Mike Ruckman 2015-10-28 22:22:07 EDT
+1 blocker
Comment 4 Adam Williamson 2015-10-28 22:57:57 EDT
That's +3, accepted for now. Will be considered further at Go/No-Go tomorrow; we will have RC7 with this change, and RC6 without, so we have choices.
Comment 5 Adam Williamson 2015-10-29 19:17:50 EDT
Folks have said this looks good in RC9.
Comment 6 Adam Williamson 2015-10-29 19:37:54 EDT
For the record, this was discussed at 2015-10-29 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2015-10-29/f23-final-go_no_go-meeting_2.2015-10-29-16.00.html . The decision to accept it as a blocker was generally affirmed.
Comment 7 Lukas Brabec 2015-10-30 05:38:13 EDT
Looks good in RC10.
Comment 8 Adam Williamson 2015-11-02 18:13:12 EST
Update was included in RC10 and pushed stable.

Note You need to log in before you can comment on or make changes to this bug.