Bug 1276204 - OS::Neutron::Subnet should not be deleted/created when allocation_pools is updated
OS::Neutron::Subnet should not be deleted/created when allocation_pools is up...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z3
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: TestOnly, ZStream
Depends On:
Blocks: 1269285 1272357
  Show dependency treegraph
 
Reported: 2015-10-29 01:15 EDT by Giulio Fidente
Modified: 2016-04-26 19:50 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.1-8.el7ost
Doc Type: Bug Fix
Doc Text:
The allocation_pools property of the OS::Neutron::Subnet resource was marked as not allowing updates. Consequently, if the allocation_pools property changed, the Subnet resource was replaced, and this generally failed if there was any overlap. The property is now marked to allow in-place updates. As a result, if the allocation_pools property changes, the existing Subnet will be updated with the new value.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:01:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1510338 None None None Never
OpenStack gerrit 242181 None None None Never

  None (edit)
Description Giulio Fidente 2015-10-29 01:15:15 EDT
Description of problem:
when trying to update a subnet resource with a new allocation pool, the subnet resource seems to get deleted and recreated with the new properties

this causes troubles when updating for example a tripleo overcloud with updated pools for the isolated networks
Comment 2 Zane Bitter 2015-11-05 14:12:59 EST
Upstream backport proposed.
Comment 5 Amit Ugol 2015-11-23 11:03:09 EST
update passed in CI
Comment 7 errata-xmlrpc 2015-12-21 12:01:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2680

Note You need to log in before you can comment on or make changes to this bug.