Bug 1276208 - [RFE] 'gluster volume help' output could be sorted alphabetically
[RFE] 'gluster volume help' output could be sorted alphabetically
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mohamed Ashiq
: EasyFix, FutureFeature, Triaged
Depends On: 1193298 1242894
Blocks: glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-10-29 01:40 EDT by Mohamed Ashiq
Modified: 2015-11-17 01:01 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1242894
Environment:
Last Closed: 2015-11-17 01:01:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-10-29 01:40:45 EDT
+++ This bug was initially created as a clone of Bug #1242894 +++

+++ This bug was initially created as a clone of Bug #1193298 +++

Description of problem:
-----------------------
'gluster volume help' output is not sorted alphabetically.
This makes little harder for the user to search or get to know of few gluster volume commands usage just from gluster cli.

This could be improved by sorting the volume subset alphabetically

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Execute 'gluster volume help' on CLI

Actual results:
---------------
all volume subset options are not sorted alphabetically

Expected results:
-----------------
Volume subset options should be sorted

Additional info:
----------------
Current output looks like this,

[~]# gluster v help
volume info ...
volume create ...
volume delete ...
volume start ...
volume stop ...
volume add-brick ...
volume remove-brick ...
volume rebalance ...
volume replace-brick ... 
volume set ...
volume help ...
'
'
volume clear-locks ...

It could be sorted alphabetically as,
[~]# gluster v help
volume add-brick ...

volume create ...
volume clear-locks ...
volume delete ...
volume help ...
volume info ...
volume rebalance ...
volume remove-brick ...
volume replace-brick ... 
'
'
volume set ...
volume start ...
volume stop ...
'
'

The justification is that future days could bring in more new options to 'volume' command, and it is difficult to search through that output.

--- Additional comment from Anand Avati on 2015-07-14 08:20:38 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#2) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-15 04:59:07 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#3) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-16 02:46:06 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#4) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-23 02:56:37 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#5) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-28 11:21:31 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#6) for review on master by Mohamed Ashiq (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-03 01:35:58 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#8) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-05 03:20:31 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#9) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Anand Avati on 2015-08-05 05:05:14 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#10) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-09-15 12:28:58 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#13) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-27 03:12:20 EDT ---

REVIEW: http://review.gluster.org/11663 (cli : 'gluster volume help' output sorted alphabetically) posted (#14) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-10-28 16:42:35 EDT ---

COMMIT: http://review.gluster.org/11663 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 323e71617fee5020324540776d0d4469577f0afe
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Wed Jul 15 14:19:49 2015 +0530

    cli : 'gluster volume help' output sorted alphabetically
    
    'gluster volume help' output is not sorted alphabetically.
    This makes little harder for the user to search or get to know of
    few gluster volume commands usage just from gluster cli.
    
    Change-Id: I855da2e4748a5c2ff3be319c50fa9548d676ee8a
    BUG: 1242894
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/11663
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
Comment 1 Vijay Bellur 2015-10-29 01:56:18 EDT
REVIEW: http://review.gluster.org/12452 (cli : 'gluster volume help' output sorted alphabetically) posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-11-02 05:03:31 EST
COMMIT: http://review.gluster.org/12452 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 0b6f0e09715fb2ba8f86bd80b05d552ae75aeda9
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Wed Jul 15 14:19:49 2015 +0530

    cli : 'gluster volume help' output sorted alphabetically
    
    'gluster volume help' output is not sorted alphabetically.
    This makes little harder for the user to search or get to know of
    few gluster volume commands usage just from gluster cli.
    
        Backport of http://review.gluster.org/11663
    
    Cherry picked from 323e71617fee5020324540776d0d4469577f0afe
    Change-Id: I855da2e4748a5c2ff3be319c50fa9548d676ee8a
    BUG: 1276208
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    >Reviewed-on: http://review.gluster.org/11663
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    >Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/12452
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
Comment 3 Raghavendra Talur 2015-11-17 01:01:43 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.