Bug 1276230 - [GlusterD]: Invalid peer probe Error message is not correct in cmd_history.log file
[GlusterD]: Invalid peer probe Error message is not correct in cmd_history.l...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 03:08 EDT by Byreddy
Modified: 2015-11-02 07:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 07:32:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2015-10-29 03:08:50 EDT
Description of problem:
-----------------------
After peer probing invalid host(Not existing host), got the  error message "time out" in the command console, but in the cmd_history.log file,  the error message logged is ""FAILED : Probe returned with Transport endpoint is not connected"

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
glusterfs-3.7.5-0.3

How reproducible:
-----------------
Always


Steps to Reproduce:
-------------------
1.Peer probe in valid host (eg: gluster peer probe x.x.x.x  where x is numeric)
2.Check the error message in the cmd_history.log file  for the peer probe in step-1
3. Check, there will be mis match of error message got in step-1 and step-2

Actual results:
---------------
In the command console getting the error message "Error : Request timed out" and in the cmd_history.log file "FAILED : Probe returned with Transport endpoint is not connected"


Expected results:
-----------------
Error message should be same in command console and in cmd_history.log file.

Additional info:
Comment 2 Atin Mukherjee 2015-10-29 23:28:37 EDT
I think this has happened due to the design. cmd_history log file is maintained by glusterd not cli. So even a cli command times out (in your case that happened) glusterD can actually go ahead and process the command and log the success or failure (in this particular case the command failed)

Note You need to log in before you can comment on or make changes to this bug.