Bug 1276243 - gluster-nfs : Server crashed due to an invalid reference
gluster-nfs : Server crashed due to an invalid reference
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All All
urgent Severity urgent
: ---
: ---
Assigned To: Jiffin
: Triaged
Depends On:
Blocks: 1276244
  Show dependency treegraph
 
Reported: 2015-10-29 04:42 EDT by Jiffin
Modified: 2016-06-16 09:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1276244 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-10-29 04:42:25 EDT
Description of problem:

While testing gluster nfs with tiering, a crash is observed on different scenarios when fop such as access,read etc is performed. This issue is due to the invalid usage of null referenced variable 

Version-Release number of selected component (if applicable):
mainline

Actual results:
Crash is seen at different fops like read, access etc

Expected results:
Server should not crash even if fop failed.
Comment 1 Vijay Bellur 2015-10-29 04:43:03 EDT
REVIEW: http://review.gluster.org/12458 (nfs : avoid invalid usage of `cs` variable in nfs fops) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2015-10-29 06:13:00 EDT
REVIEW: http://review.gluster.org/12458 (nfs : avoid invalid usage of `cs` variable in nfs fops) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Vijay Bellur 2015-10-29 08:08:01 EDT
REVIEW: http://review.gluster.org/12458 (nfs : avoid invalid usage of `cs` variable in nfs fops) posted (#3) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2015-10-30 04:54:57 EDT
COMMIT: http://review.gluster.org/12458 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ee4f6175d1e1e6d6b82631d72c993db5691ad205
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Thu Oct 29 12:29:04 2015 +0530

    nfs : avoid invalid usage of `cs` variable in nfs fops
    
    Due to changes from http://review.gluster.org/#/c/12162/ a path variable
    is added to nfs3_log_common_res() and usually `cs->resolvedloc.path` is
    passed for that. But in certain fop function `cs` may not filled due error
    and when it is logged using nfs3_log_common_res() results in a crash.
    This patch will fix the same.
    
    Change-Id: I5a709818923e7884bd04e329834ee352a1b3a58f
    BUG: 1276243
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12458
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:41:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.