Bug 1276262 - Do not collect /proc/net/cdp by networking plugin
Do not collect /proc/net/cdp by networking plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: 6.6
Assigned To: Shane Bradley
Miroslav Hradílek
: Regression
Depends On:
Blocks: 1172231 1274384
  Show dependency treegraph
 
Reported: 2015-10-29 05:46 EDT by Martin Frodl
Modified: 2016-05-10 17:07 EDT (History)
13 users (show)

See Also:
Fixed In Version: sos-3.2-39.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1004936
: 1290741 (view as bug list)
Environment:
Last Closed: 2016-05-10 17:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel module for reproducer (10.00 KB, application/x-tar)
2015-10-29 05:46 EDT, Martin Frodl
no flags Details

  None (edit)
Description Martin Frodl 2015-10-29 05:46:11 EDT
Created attachment 1087436 [details]
Kernel module for reproducer

To fix bug 1004936, /proc/net/cdp was added to forbidden paths in order to prevent collecting possibly gigantic files that can be present in this directory. After rebase to sos 3.2, this path is not on the blacklist anymore.

Version-Release number of selected component (if applicable):
sos-3.2-28.el6.noarch

How reproducible:
While I have not directly encountered the space consumption issue reported in the original bug, it can be shown that /proc/net/cdp is currently indeed collected by sosreport.

Steps to Reproduce:
1. Download and extract cdp.tar from attachment
2. In the extracted directory, build kernel module that creates /proc/net/cdp:
   # make
   # insmod cdp.ko
3. Run sosreport (networking module is enough):
   # sosreport -o networking --batch
4. List files contained in the resulting archive:
   # tar tvf /var/tmp/sosreport-<something>.tar.xz

Actual results:
The archive contains /proc/net/cdp and everything in it.

Expected results:
/proc/net/cdp is not collected.

Additional info:
I have not explicitly checked if /sys/net/cdp needs to be blacklisted again too, but I am sure there is a good reason to do so.

+++ This bug was initially created as a clone of Bug #1004936 +++
Comment 13 errata-xmlrpc 2016-05-10 17:07:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0819.html

Note You need to log in before you can comment on or make changes to this bug.