Bug 1276278 - Keyboard indicatior displaying us keyboard even after selecting other layout
Keyboard indicatior displaying us keyboard even after selecting other layout
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 06:34 EDT by kakoskin
Modified: 2015-11-05 09:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 09:45:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kakoskin 2015-10-29 06:34:46 EDT
Description of problem:
When installing using KDE Live RC6, keyboard indicator is displaying US keyboard even after selecting Finnish keyboard. Anaconda is using Finnish layout. Only the indicator is wrong. 

How reproducible:
Start install without setting keyboard in Live image. In installation select keyboard layout other than English. Return to hub from keyboard spoke 

Actual results:
Keyboard is indicator is displaying US instead of correct layout.

Expected results:
Keyboard indicator displays selected (and currently in use) layout.
Comment 1 kakoskin 2015-10-29 07:38:22 EDT
I did not observe this bug when installing with language set to English and keyboard selected to Finnish.
Comment 2 kakoskin 2015-10-29 09:03:50 EDT
I did not observe this bug when installing from Workstation netinstall.iso
Comment 3 David Shea 2015-11-02 10:51:01 EST
Please attach the logs from /tmp to this bug as individual, text/plain attachments. Also, what were the exact steps you took to change the keyboard layout? What language did you select on the welcome screen, and what actions did you take afterwards?
Comment 4 kakoskin 2015-11-05 08:22:38 EST
Sadly I didn't save logs from this install, expecting to see it again. I haven't been able to reproduce this bug again in multible attempts. 

- I simply started install from RC6 KDE Live image.

- I clicked continue when installer offered Finnish as succested language. 
On hub screen I observed that keyboard indicator was showing us and not fi as 
expected. 

- I clicked on keyboard layouts spoke.

- I clicked + symbol, selected Finnish (Finnish (Machintosh)) layout and accepted selection.

- I selected us keyboard layout in the list of selected layouts and clicked - symbol to remove it. 

- I clicked Done button and returned to hub screen, where keyboard indicator was still showing us.

- I proceeded to complete installation with minimal choices from there on. User creation and diskencryption passphrases confirmed that keyboard in use was in fact what I had selected.
Comment 5 David Shea 2015-11-05 09:45:14 EST
I'm not able to reproduce this either. Please reopen the bug if it occurs again.

Note You need to log in before you can comment on or make changes to this bug.