Bug 127629 - Resolution does not change automatically when docked
Resolution does not change automatically when docked
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 12:19 EDT by Chris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 17:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf file used on affected laptop (2.65 KB, text/plain)
2004-07-11 12:25 EDT, Chris
no flags Details

  None (edit)
Description Chris 2004-07-11 12:19:15 EDT
Description of problem:
I installed FC2 on my Dell Inspiron 8500 with it undocked and had to
modify xorg.conf to allow for my 1920x1200 screen resolution as I had
to do with FC1.  However, when docked the screen remains at 1920x1200
resolution.  With FC1 and XFree86, the resolution switched
automatically between 1920x1200 (undocked) and 1600x1200 (docked)
depending on the docked status.  

Version-Release number of selected component (if applicable):
- Fedora Core release 2 (Tettnang)
- xorg-x11-6.7.0-5

How reproducible:
See steps below

Steps to Reproduce:
1. Install FC2 on laptop with non-standard display capability
2. modify /etc/X11/xorg.conf by adding 1920x1200 to front of Screen
modes list
3. Reboot undocked.  X11 will properly display 1920x1200 on laptop LCD
4. Reboot docked.  X11 will improperly display 1920x1200 on external CRT
  
Actual results:
When docked, resolution remains at 1920x1200

Expected results:
When docked, resolution should default back to 1600x1200

Additional info:
Please find my /etc/X11/xorg.conf attached.
Comment 1 Chris 2004-07-11 12:25:01 EDT
Created attachment 101795 [details]
/etc/X11/xorg.conf file used on affected laptop

I am no X11 expert, but a similar configuration worked in XFree86.
Comment 2 Chris 2004-07-11 12:28:37 EDT
Just FYI, my current work-around is to manually change the screen
resolution every time I login using the gnome-display-properties tool.
 This is undesirable because this wasn't required when using FC1 and
XFree86.   
Comment 3 Mike A. Harris 2004-08-31 13:31:26 EDT
This seems to be a configuration issue, but it isn't completely
clear.  Please file a bug report in upstream X.org bugzilla at
http://bugs.freedesktop.org in the "xorg" component, in order
to maximize the number of potential developers aware of this
issue who may be able to investigate and/or make a suggestion.

If you paste your upstream bug URL here, we will also track the
issue in upstream bugzilla.
Comment 4 Chris 2004-08-31 13:41:22 EDT
I will open the bug with X.org.  Will post URL when it's available.  

The reason why I don't believe this is a configuration issue is that
the desired behavior was acheived by simply switching to the Nvidia
binary driver.  

I know RH cannot support Nvidia's release without source code. 
There's no way of telling what it's doing to automagically adjust the
screen res.  

Perhaps this bug would be more appropriately filed against the nv
video driver?  However, I didn't see 'nv' in the component list so
this was the best I could do.  
Comment 5 Mike A. Harris 2004-08-31 17:32:45 EDT
We don't have a separate component per driver, just for the X
package as a whole.

The "nv" driver, while open source code, is mostly useless unless
you are an Nvidia employee, as it is completely obfuscated and
programs registers on the hardware by hexadecimal register number,
with hex values.  The hardware documentation is also unavailable.

In order to have a bug in the "nv" driver investigated and fixed,
one needs to report the bug to X.Org directly, and hopefully
the "nv" driver maintainer or someone from Nvidia can investigate
the issue.  We can then track the issue in the upstream bugzilla
once we're made aware of the URL, and consider using any bugfixes
that become available.  We do not directly develop the "nv" driver
or have knowledge of Nvidia hardware operation however, so we're
reliant on Nvidia to provide bug fixes and hardware updates.

Thanks for reporting upstream.

Setting status to "UPSTREAM", and awaiting bug URL for tracking.

Comment 6 Chris 2004-08-31 22:17:10 EDT
See included upstream bugzilla link

Note You need to log in before you can comment on or make changes to this bug.