Bug 1276323 - Most Pod created from guestbook example keep in ImagePullBackOff status although images have been pulled beforehand
Summary: Most Pod created from guestbook example keep in ImagePullBackOff status altho...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Paul Weil
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-29 13:07 UTC by Wenjing Zheng
Modified: 2015-11-23 14:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-23 14:24:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2015-10-29 13:07:49 UTC
Description of problem:
Pod keeps in ImagePullBackOff status although image exists in nodes:
[wzheng@localhost test]$ oc get pods
NAME                 READY     STATUS             RESTARTS   AGE
frontend-moe8i       0/1       ImagePullBackOff   0          3m
frontend-yh3tm       0/1       ImagePullBackOff   0          3m
frontend-zzut6       0/1       ImagePullBackOff   0          3m
redis-master-ey88p   1/1       Running            0          4m
redis-slave-6n0s8    0/1       ImagePullBackOff   0          3m
redis-slave-xwt3l    0/1       ImagePullBackOff   0          3m


Version-Release number of selected component (if applicable):
openshift v3.0.2.903-114-g2849767
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
always

Steps to Reproduce:
0. Change scc
Before testing, please add "- system:authenticated" to scc/privileged group and remove it from scc/restricted.
$oc edit scc/restricted
$oc edit scc/privileged
groups:
- system:cluster-admins
- system:nodes
- system:authenticated
1. Create a project
2. Create with guestbook example
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/redis-master-controller.yaml
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/redis-master-service.yaml
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/redis-slave-controller.yaml
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/redis-slave-service.yaml
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/frontend-controller.yaml
$oc create -f https://raw.githubusercontent.com/kubernetes/kubernetes/master/examples/guestbook/frontend-service.yaml

3. Check the pods are running
$oc get pods

Actual results:
pod allways in ImagePullBackOff status

Expected results:
[fedora@ip-172-18-11-225 ~]$ oc get pods
NAME                 READY     STATUS    RESTARTS   AGE
frontend-bgs6k       1/1       Running   0          4m
frontend-vy4ju       1/1       Running   0          4m
frontend-w5236       1/1       Running   0          4m
redis-master-fhvoh   1/1       Running   0          4m
redis-slave-d6yy0    1/1       Running   0          4m
redis-slave-zpjbp    1/1       Running   0          4m


Additional info:

Comment 2 Paul Weil 2015-10-29 14:51:07 UTC
It looks like the images it is trying to pull are both gcr.io images.  On my test they took longer than three minutes.  Can you verify that gcr.io/google_samples/gb-frontend:v3 is actually on the node in 'docker images'?

Comment 3 Wenjing Zheng 2015-10-30 02:18:51 UTC
Thanks, Paul! I just pulled redis, didn't pull gcr.io/google_samples/gb-frontend:v3, pod is running now after images are ready.

Comment 4 Brenton Leanhardt 2015-11-23 14:24:43 UTC
This fix is available in OpenShift Enterprise 3.1.


Note You need to log in before you can comment on or make changes to this bug.