Bug 1276330 - [heketi-cli] Incorrect error message when storage-host-name is missing while adding a node
[heketi-cli] Incorrect error message when storage-host-name is missing while ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Luis Pabón
Anush Shetty
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-10-29 09:30 EDT by Anush Shetty
Modified: 2016-11-08 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version: heketi-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:48:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-10-29 09:30:48 EDT
Description of problem: heketi-cli exits with an incorrect error message when the value storage-host-name is missing while adding a node.


Version-Release number of selected component (if applicable): heketi-1.0.0-1.el7rhgs.x86_64


How reproducible: Always


Steps to Reproduce:
1. heketi-cli -user="admin" -secret="Top Secret" node add -cluster=fe5f47e19eaafb538baa429c734a647c -zone=2 -management-host-name=hostname

2. 
3.

Actual results:

Error: Missing management hostname


Expected results:

Should error saying that the storage hostname is missing.

Additional info:
Comment 2 Luis Pabón 2015-10-29 21:30:03 EDT
Github issue: https://github.com/heketi/heketi/issues/235
Comment 4 Anush Shetty 2015-12-01 08:01:42 EST
Verified with heketi-1.0.1-1.el7rhgs.x86_64
Comment 6 errata-xmlrpc 2016-03-01 00:48:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.