Bug 1276333 - Anaconda crashes upon probing iSCSI LUN with existing LVM structures
Anaconda crashes upon probing iSCSI LUN with existing LVM structures
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 09:35 EDT by Richard Bradfield
Modified: 2015-10-30 08:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 08:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (22.73 KB, text/plain)
2015-10-29 09:35 EDT, Richard Bradfield
no flags Details
Storage log (117.36 KB, text/plain)
2015-10-29 09:44 EDT, Richard Bradfield
no flags Details
program.log (54.01 KB, text/plain)
2015-10-29 09:45 EDT, Richard Bradfield
no flags Details
dnf.librepo.log (139.41 KB, text/plain)
2015-10-29 09:46 EDT, Richard Bradfield
no flags Details
dnf.log (10.75 KB, text/plain)
2015-10-29 09:47 EDT, Richard Bradfield
no flags Details
dnf.rpm.log (49 bytes, text/plain)
2015-10-29 09:52 EDT, Richard Bradfield
no flags Details
hawkey.log (3.01 KB, text/plain)
2015-10-29 09:52 EDT, Richard Bradfield
no flags Details
ifcfg.log (41.08 KB, text/plain)
2015-10-29 09:53 EDT, Richard Bradfield
no flags Details
packaging.log (770 bytes, text/plain)
2015-10-29 09:54 EDT, Richard Bradfield
no flags Details
X.log (28.42 KB, text/plain)
2015-10-29 09:55 EDT, Richard Bradfield
no flags Details

  None (edit)
Description Richard Bradfield 2015-10-29 09:35:25 EDT
Created attachment 1087478 [details]
Anaconda log

Description of problem:
If an exported iSCSI LUN already contains LVM labels which match those autogenerated by the guided partitioning system, Anaconda will crash and the host will reboot when you attempt to probe the LUN (immediately after clicking "Login" at the iSCSI target selection window).

This could feasibly be encountered any time a user decides to perform a clean install, the installer should recognize the existing LVM volume group and either handle overwriting it, or alert the user to its existence.

Version-Release number of selected component (if applicable):
anaconda: /sbin/anaconda 23.19.10-1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora in a /boot on local | root on SAN iSCSI config with default guided partitioning.
2. Attempt to repeat the process without first wiping the exported LUN.


Actual results:
Anaconda crashes upon logging into the target and probing LUNs.

Expected results:
Anaconda should recognise and handle the old LVM volume group.
Comment 1 David Shea 2015-10-29 09:40:15 EDT
Please attach the other logs from /tmp at the time of this crash, in particular /tmp/anaconda-tb*
Comment 2 Richard Bradfield 2015-10-29 09:44 EDT
Created attachment 1087481 [details]
Storage log
Comment 3 Richard Bradfield 2015-10-29 09:45 EDT
Created attachment 1087482 [details]
program.log
Comment 4 Richard Bradfield 2015-10-29 09:46:22 EDT
There are no files matching that criteria in /tmp, only /tmp/anaconda.log

I will attach the other logs although I believe them unrelated.
Comment 5 Richard Bradfield 2015-10-29 09:46 EDT
Created attachment 1087512 [details]
dnf.librepo.log
Comment 6 Richard Bradfield 2015-10-29 09:47 EDT
Created attachment 1087526 [details]
dnf.log
Comment 7 Fedora Blocker Bugs Application 2015-10-29 09:48:46 EDT
Proposed as a Blocker for 23-final by Fedora user bradfirj using the blocker tracking app because:

 I believe this bug violates the "Network attached storage" blocker criteria:

The installer must be able to detect (if possible) and install to supported network-attached storage devices.

Supported types
Supported network-attached storage types include iSCSI, Fibre Channel and Fibre Channel over Ethernet (FCoE).
Comment 8 Richard Bradfield 2015-10-29 09:52 EDT
Created attachment 1087544 [details]
dnf.rpm.log
Comment 9 Richard Bradfield 2015-10-29 09:52 EDT
Created attachment 1087546 [details]
hawkey.log
Comment 10 Richard Bradfield 2015-10-29 09:53 EDT
Created attachment 1087547 [details]
ifcfg.log
Comment 11 Richard Bradfield 2015-10-29 09:54 EDT
Created attachment 1087548 [details]
packaging.log
Comment 12 Richard Bradfield 2015-10-29 09:55 EDT
Created attachment 1087549 [details]
X.log
Comment 13 David Shea 2015-10-29 09:56:31 EDT
As noted in your initial comment, and in the traceback, you have more than LVM volume group with the same name: one on a localally attached disk, and one on a disk being attached via iSCSI. LVM cannot handle this situation. Normally if anaconda detects mutliple VGs with the same name it will display a dialog advising the user to manually correct the storage, but this dialog is not currently displayed when a volume group is added from network storage.
Comment 14 Richard Bradfield 2015-10-29 10:09:40 EDT
It's worth noting this only presents if we try and install to an iSCSI volume when there is already an LVM volume group on both the network LUN and the local disk.

It's therefore probably enough of an edge case not to block on it, apologies for the false alarm.
Comment 15 Richard Bradfield 2015-10-29 10:10:37 EDT
(In reply to Richard Bradfield from comment #14)
> It's worth noting this only presents if we try and install to an iSCSI
> volume when there is already an LVM volume group on both the network LUN and
> the local disk.
> 
> It's therefore probably enough of an edge case not to block on it, apologies
> for the false alarm.

IE It requires at least two attempts (successful or not) at installing the OS before it can occur.
Comment 16 Stephen Gallagher 2015-10-29 10:12:13 EDT
OK, based on the discussion summarized here, I'm firmly -1 blocker on this issue.
Comment 17 David Shea 2015-10-29 10:36:58 EDT
FWIW this is fixed in rawhide by https://github.com/rhinstaller/anaconda/commit/5da4ee6b8825c52d7a75dba2012aff2efa595c8b
Comment 18 Adam Williamson 2015-10-29 19:32:06 EDT
Discussed at 2015-10-29 Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2015-10-29/f23-final-go_no_go-meeting_2.2015-10-29-16.00.html . Rejected as a blocker on the basis that this is a fairly unusual corner case, does not constitute a violation of the criterion - in most cases, iSCSI installs will work OK.
Comment 19 David Shea 2015-10-30 08:48:33 EDT
Closing this since it will not be going into F23 and is already in rawhide.

Note You need to log in before you can comment on or make changes to this bug.