Bug 1276340 - [heketi-cli] Inconsistency with the requirement for zone value
Summary: [heketi-cli] Inconsistency with the requirement for zone value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.1.2
Assignee: Luis Pabón
QA Contact: Anush Shetty
URL:
Whiteboard:
Depends On:
Blocks: 1260783
TreeView+ depends on / blocked
 
Reported: 2015-10-29 13:41 UTC by Anush Shetty
Modified: 2016-11-08 22:24 UTC (History)
3 users (show)

Fixed In Version: heketi-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-01 05:48:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 10:20:36 UTC

Description Anush Shetty 2015-10-29 13:41:43 UTC
Description of problem: When the nodes are added through a topology file, zone value isn't mandatory but adding a node through cli expects a zone value. 


Version-Release number of selected component (if applicable): heketi-devel-1.0.0-1.el7rhgs.noarch


How reproducible: Always


Additional info:

CLI:

# heketi-cli -user="admin" -secret="Top Secret" node add -cluster=fe5f47e19eaafb538baa429c734a647c -management-host-name=hostname

Error: Missing zone

But this worked:

#heketi-cli load -json=topology.json

cat topology.json
{
    "clusters": [
        {
            "nodes": [
                {
                    "node": {
                        "hostnames": {
                            "manage": [
                                "rhshdp04.lab.eng.blr.redhat.com"
                            ],
                            "storage": [
                                "rhshdp04.lab.eng.blr.redhat.com"
                            ]
                        }

                    },
                    "devices": [
                        "/dev/vdb",
                        "/dev/vdc",
                        "/dev/vdd"
                    ]
                }
            ]
         }
     ]
}

Comment 2 Luis Pabón 2015-10-30 01:32:42 UTC
Github issue: https://github.com/heketi/heketi/issues/236

Comment 4 Anush Shetty 2015-11-09 06:50:52 UTC
Verified with heketi-1.0.1-1.el7rhgs.x86_64

Comment 6 errata-xmlrpc 2016-03-01 05:48:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html


Note You need to log in before you can comment on or make changes to this bug.