Bug 1276342 - SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file plugin-container.
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file plugin-...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a65242a1a66e2b7b9cb6d84a51b...
:
: 1284050 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 09:48 EDT by Martín Cigorraga
Modified: 2015-12-11 04:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 06:47:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martín Cigorraga 2015-10-29 09:48:41 EDT
Description of problem:
On an F23 RC3 fresh installed, upgraded (including updates-testing) and rebooted.
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file plugin-container.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed read access on the plugin-container file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:mozilla_plugin_exec_t:s0
Target Objects                plugin-container [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-29 10:45:05 ART
Last Seen                     2015-10-29 10:45:05 ART
Local ID                      31cc5d8f-da94-4c83-8ccd-670d5d2a4db3

Raw Audit Messages
type=AVC msg=audit(1446126305.582:698): avc:  denied  { read } for  pid=10346 comm="abrt-hook-ccpp" name="plugin-container" dev="dm-2" ino=160428 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:mozilla_plugin_exec_t:s0 tclass=file permissive=1


Hash: abrt-hook-ccpp,abrt_dump_oops_t,mozilla_plugin_exec_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-02 06:47:23 EST

*** This bug has been marked as a duplicate of bug 1276305 ***
Comment 2 Miroslav Grepl 2015-12-11 04:51:02 EST
*** Bug 1284050 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.