Bug 1276346 - Docker Service Crash
Docker Service Crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: 7.2
Assigned To: Lokesh Mandvekar
chaoyang
: Extras, UpcomingRelease
Depends On:
Blocks: 1319783
  Show dependency treegraph
 
Reported: 2015-10-29 10:02 EDT by Miheer Salunke
Modified: 2016-03-21 10:09 EDT (History)
11 users (show)

See Also:
Fixed In Version: docker-1.8.2-10.el7
Doc Type: Bug Fix
Doc Text:
Previously, if the Docker service crashed on a node, it did not automatically restart. As a result, you would need to log in to the master itself and manually start the service in order to have the environment running properly. Now, this has been fixed, and the Docker service is automatically restarted after a failure.
Story Points: ---
Clone Of:
: 1319783 (view as bug list)
Environment:
Last Closed: 2015-12-08 10:36:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 9 errata-xmlrpc 2015-12-08 10:36:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2554.html
Comment 10 Vivek Goyal 2016-03-21 10:07:43 EDT
I am reopening this bug. Instead of Restart=on-failure, we should consider using Restart=on-abnormal.

Reason being that otherwise we try to restart docker multiple times even when docker can't start and has configuration issues. And as a result, it forces restart of docekr-storage-setup and all I see in logs is following.


 systemd[1]: docker.service failed.
 systemd[1]: start request repeated too quickly for docker.service
 systemd[1]: Failed to start Docker Application Container Engine.

Note You need to log in before you can comment on or make changes to this bug.