Bug 1276349 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
Summary: AttributeError: 'NoneType' object has no attribute 'mountpoints'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:82cdf3983f18fc9609994254c40...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-29 14:08 UTC by Alexander Todorov
Modified: 2015-11-09 09:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-09 09:58:35 UTC


Attachments (Terms of Use)
File: anaconda-tb (1.65 MB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: anaconda.log (49.44 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: dnf.log (33.90 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: dnf.rpm.log (26.94 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: environ (3.52 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: journalctl (1.06 MB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: lsblk_output (1.55 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: nmcli_dev_list (2.17 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: program.log (149.03 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: storage.log (334.84 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details
File: packaging.log (1.94 KB, text/plain)
2015-10-29 14:08 UTC, Alexander Todorov
no flags Details

Description Alexander Todorov 2015-10-29 14:08:05 UTC
Description of problem:
Try running anaconda with --image option.

If running from a git checkout then (as root):

# export top_srcdir=`pwd`
# . ./tests/testenv.sh
# ./anaconda -G --image /path/to/disk.img

where disk.img has been created with dd:
dd if=/dev/zero of=disk.img bs=1M count=1 seek=10240

The same -G --image disk.img options work perfectly with anaconda 21.48.22.55-1 (RHEL 7).

Version-Release number of selected component:
anaconda-24.5-0.1.20151029122830

The following was filed automatically by anaconda:
anaconda 24.5-0.1.20151029122830 exception report
Traceback (most recent call first):
  File "/home/atodorov/anaconda/pyanaconda/packaging/dnfpayload.py", line 557, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/home/atodorov/anaconda/pyanaconda/ui/lib/space.py", line 76, in check
    needed = self.payload.spaceRequired
  File "/home/atodorov/anaconda/pyanaconda/ui/gui/hubs/__init__.py", line 238, in _updateContinue
    if self._checker and not self._checker.check():
  File "/home/atodorov/anaconda/pyanaconda/ui/gui/hubs/__init__.py", line 212, in _createBox
    self._updateContinue()
  File "/home/atodorov/anaconda/pyanaconda/ui/gui/hubs/__init__.py", line 344, in refresh
    self._createBox()
  File "/home/atodorov/anaconda/pyanaconda/ui/gui/__init__.py", line 825, in run
    self._currentAction.refresh()
  File "./anaconda", line 1198, in <module>
    anaconda._intf.run()
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
addons:         org_fedora_realm
cmdline:        /usr/bin/python3  ./anaconda -G --image /var/lib/libvirt/images/disk1.img
cmdline_file:   BOOT_IMAGE=/vmlinuz-4.3.0-0.rc5.git2.1.fc24.x86_64 root=/dev/mapper/fedora_tyan--gt24--05-root ro rd.lvm.lv=fedora_tyan-gt24-05/root rd.lvm.lv=fedora_tyan-gt24-05/swap console=ttyS0,115200 LANG=en_US.UTF-8
executable:     ./anaconda
hashmarkername: anaconda
kernel:         4.3.0-0.rc5.git2.1.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        rawhide

Comment 1 Alexander Todorov 2015-10-29 14:08:12 UTC
Created attachment 1087550 [details]
File: anaconda-tb

Comment 2 Alexander Todorov 2015-10-29 14:08:14 UTC
Created attachment 1087551 [details]
File: anaconda.log

Comment 3 Alexander Todorov 2015-10-29 14:08:15 UTC
Created attachment 1087552 [details]
File: dnf.log

Comment 4 Alexander Todorov 2015-10-29 14:08:17 UTC
Created attachment 1087553 [details]
File: dnf.rpm.log

Comment 5 Alexander Todorov 2015-10-29 14:08:18 UTC
Created attachment 1087554 [details]
File: environ

Comment 6 Alexander Todorov 2015-10-29 14:08:22 UTC
Created attachment 1087555 [details]
File: journalctl

Comment 7 Alexander Todorov 2015-10-29 14:08:23 UTC
Created attachment 1087556 [details]
File: lsblk_output

Comment 8 Alexander Todorov 2015-10-29 14:08:24 UTC
Created attachment 1087557 [details]
File: nmcli_dev_list

Comment 9 Alexander Todorov 2015-10-29 14:08:25 UTC
Created attachment 1087558 [details]
File: os_info

Comment 10 Alexander Todorov 2015-10-29 14:08:27 UTC
Created attachment 1087559 [details]
File: program.log

Comment 11 Alexander Todorov 2015-10-29 14:08:29 UTC
Created attachment 1087560 [details]
File: storage.log

Comment 12 Alexander Todorov 2015-10-29 14:08:30 UTC
Created attachment 1087561 [details]
File: packaging.log

Comment 13 Alexander Todorov 2015-10-29 14:10:32 UTC
Adding TestBlocker keyword and bumping Prio/Sev. This not working is blocking my attempts to refactor tests/ui/ to work on a disk image instead of LiveCD.

Comment 14 Brian Lane 2015-11-06 19:21:20 UTC
Did you get this sorted out with your other changes to the environment? I'm opposed to making this a TestBlocker unless it happens from an installed anaconda.

Comment 15 Alexander Todorov 2015-11-09 09:24:22 UTC
Clearing TestBlocker. I will try to reproduce one more time and if I can't reproduce it reliably I will close this bug.

Comment 16 Alexander Todorov 2015-11-09 09:58:35 UTC
Can't reproduce with the latest changes, closing.


Note You need to log in before you can comment on or make changes to this bug.