Bug 1276365 - Please, make gcc.rpm installed by default in systemtap containers.
Please, make gcc.rpm installed by default in systemtap containers.
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-meta (Show other bugs)
DTS 4.0 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 4.1
Assigned To: Marek Polacek
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 10:31 EDT by Martin Cermak
Modified: 2016-05-31 04:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 04:43:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1149 normal SHIPPED_LIVE devtoolset-4 bug fix and enhancement update 2016-05-31 08:38:52 EDT

  None (edit)
Description Martin Cermak 2015-10-29 10:31:41 EDT
Systemtap by default prefers to use base rhel compiler to build its kernel modules even if collection compiler is installed and the collection is turned on.

Systemtap dockerfile we ship with DTS-4.0 does not make base rhel compiler installed by default. So the user might need to install it by hand. We are documenting this for now. For future releases of DTS we might want to install gcc.rpm by default for user convenience.
Comment 1 Marek Polacek 2015-11-02 07:35:59 EST
So probably just
--- a/devtoolset-4.spec
+++ b/devtoolset-4.spec
@@ -7,7 +7,7 @@
 Summary: Package that installs %scl
 Name: %scl_name
 Version: 4.0
-Release: 9%{?dist}
+Release: 10%{?dist}
 License: GPLv2+
 Group: Applications/File
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -138,6 +138,7 @@ Package shipping performance tools (systemtap, oprofile)
 
 %package dockerfiles
 Summary: Package shipping Dockerfiles for Developer Toolset
+Requires: gcc
 Group: Applications/File
 
 %description dockerfiles
@@ -435,6 +436,9 @@ if [ $1 = 0 ]; then
 fi
 
 %changelog
+* Mon Nov 02 2015 Marek Polacek <polacek@redhat.com> - 4.0-10
+- Require gcc for dockerfiles (#1276365)
+
 * Mon Oct 26 2015 Marek Polacek <polacek@redhat.com> - 4.0-9
 - Ship RHEL6 Dockerfiles on RHEL7 (#1265118)
Comment 6 errata-xmlrpc 2016-05-31 04:43:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1149

Note You need to log in before you can comment on or make changes to this bug.