Bug 1276376 - OSError: Unable to set password for new user: status=3
OSError: Unable to set password for new user: status=3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f426c8e89e0d2b3493800fcbbaf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 10:50 EDT by Alexander Todorov
Modified: 2015-11-03 03:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 03:40:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.22 MB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: anaconda.log (10.89 KB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: dnf.log (34.52 KB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: dnf.rpm.log (32.98 KB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: environ (3.17 KB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: journalctl (939.05 KB, text/plain)
2015-10-29 10:50 EDT, Alexander Todorov
no flags Details
File: lsblk_output (1.25 KB, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details
File: nmcli_dev_list (3.20 KB, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details
File: program.log (42.30 KB, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details
File: storage.log (8.92 KB, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details
File: packaging.log (23.87 KB, text/plain)
2015-10-29 10:51 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2015-10-29 10:50:44 EDT
Description of problem:
This is probably a direct result from bug #1276372.
After anaconda finished installing a set of 250 packages (I guess minimal package set) it tried to configure the root account for which I have not provided a password because there's no way to do so. On the progress screen there are no buttons to configure the root password or additinal users.

Version-Release number of selected component:
anaconda-24.5-0.1.20151029122830

The following was filed automatically by anaconda:
anaconda 24.5-0.1.20151029122830 exception report
Traceback (most recent call first):
  File "/home/atodorov/anaconda/pyanaconda/users.py", line 409, in setUserPassword
    raise OSError("Unable to set password for new user: status=%s" % proc.returncode)
  File "/home/atodorov/anaconda/pyanaconda/users.py", line 417, in setRootPassword
    return self.setUserPassword("root", password, isCrypted, isLocked, algo, root)
  File "/home/atodorov/anaconda/pyanaconda/kickstart.py", line 1618, in execute
    users.setRootPassword(self.password, self.isCrypted, self.lock, algo, iutil.getSysroot())
  File "/home/atodorov/anaconda/pyanaconda/install.py", line 94, in doConfiguration
    ksdata.rootpw.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/home/atodorov/anaconda/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: Unable to set password for new user: status=3

Additional info:
addons:         org_fedora_realm
cmdline:        /usr/bin/python3  ./anaconda -G --dirinstall /var/tmp/anaconda-install/ --repo http://example.com/repo
cmdline_file:   BOOT_IMAGE=/vmlinuz-4.3.0-0.rc5.git2.1.fc24.x86_64 root=/dev/mapper/fedora_tyan--gt24--05-root ro rd.lvm.lv=fedora_tyan-gt24-05/root rd.lvm.lv=fedora_tyan-gt24-05/swap console=ttyS0,115200 LANG=en_US.UTF-8
executable:     ./anaconda
hashmarkername: anaconda
kernel:         4.3.0-0.rc5.git2.1.fc24.x86_64
other involved packages: python3-libs-3.4.3-5.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Alexander Todorov 2015-10-29 10:50:50 EDT
Created attachment 1087569 [details]
File: anaconda-tb
Comment 2 Alexander Todorov 2015-10-29 10:50:51 EDT
Created attachment 1087570 [details]
File: anaconda.log
Comment 3 Alexander Todorov 2015-10-29 10:50:53 EDT
Created attachment 1087571 [details]
File: dnf.log
Comment 4 Alexander Todorov 2015-10-29 10:50:54 EDT
Created attachment 1087572 [details]
File: dnf.rpm.log
Comment 5 Alexander Todorov 2015-10-29 10:50:55 EDT
Created attachment 1087573 [details]
File: environ
Comment 6 Alexander Todorov 2015-10-29 10:50:59 EDT
Created attachment 1087574 [details]
File: journalctl
Comment 7 Alexander Todorov 2015-10-29 10:51:00 EDT
Created attachment 1087575 [details]
File: lsblk_output
Comment 8 Alexander Todorov 2015-10-29 10:51:02 EDT
Created attachment 1087576 [details]
File: nmcli_dev_list
Comment 9 Alexander Todorov 2015-10-29 10:51:03 EDT
Created attachment 1087577 [details]
File: os_info
Comment 10 Alexander Todorov 2015-10-29 10:51:04 EDT
Created attachment 1087578 [details]
File: program.log
Comment 11 Alexander Todorov 2015-10-29 10:51:05 EDT
Created attachment 1087579 [details]
File: storage.log
Comment 12 Alexander Todorov 2015-10-29 10:51:08 EDT
Created attachment 1087580 [details]
File: packaging.log
Comment 13 David Shea 2015-10-30 09:19:58 EDT
Is selinux enabled? I see this in the logs:

Oct 29 10:45:17 tyan-gt24-05.rhts.eng.bos.redhat.com audit[1111]: AVC avc:  denied  { sys_chroot } for  pid=1111 comm="chpasswd" capability=18  scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tclass=capability permissive=0
Comment 14 Alexander Todorov 2015-11-02 11:01:54 EST
Yes, SELinux is enabled. The strange thing however is that this appears to work when I execute anaconda as /usr/sbin/anaconda and not when I execute if from a git checkout. 

Also it doesn't appear anaconda to modify /etc/ on the host system. It's strange that we get an avc denial in one case and not in the other. 

Btw I have resolved my other issues with running from a git checkout and will submit a patch tomorrow.
Comment 15 Brian Lane 2015-11-02 21:10:34 EST
You should run it in permissive mode, running it from the checkout will confuse selinux which expects:

system_u:object_r:install_exec_t:s0 /usr/sbin/anaconda*
Comment 16 Alexander Todorov 2015-11-03 03:40:22 EST
Understood. Closing then.

Note You need to log in before you can comment on or make changes to this bug.