Bug 1276386 - vol replace-brick fails when transport.socket.bind-address is set in glusterd
vol replace-brick fails when transport.socket.bind-address is set in glusterd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed Ashiq
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 11:06 EDT by Mohamed Ashiq
Modified: 2016-06-16 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-10-29 11:06:32 EDT
Description of problem:
When you bind glusterd to a specific IP, shd operates correctly but the 'vol replace-brick' command attempts to contact glusterd on 127.0.0.1 and fails.

Version-Release number of selected component (if applicable):
glusterfs 3.7.x (and prior releases?)

How reproducible:
Every time! I noticed this in a test environment I'm using for containers, where I bind glusterd host IP.

Steps to Reproduce:
1. use transport.socket.bind-address to bind glusterd to a specific IP on each host
2.volume replace-brick <VOLNAME> <SOURCE-BRICK> <NEW-BRICK> {commit force}

Actual results:
[2015-10-29 13:32:05.603754] I [MSGID: 100030] [glusterfsd.c:2313:main] 0-/usr/local/sbin/glusterfs: Started running /usr/local/sbin/glusterfs version 3.8dev (args: /usr/local/sbin/glusterfs -s localhost --volfile-id test --client-pid -6 -l /var/log/glusterfs/test-replace-brick-mount.log /tmp/mntqxzdJu)
[2015-10-29 13:32:05.641149] I [MSGID: 101190] [event-epoll.c:627:event_dispatch_epoll_worker] 0-epoll: Started thread with index 1
[2015-10-29 13:32:05.641269] E [socket.c:2274:socket_connect_finish] 0-glusterfs: connection to 127.0.0.1:24007 failed (Connection refused)
[2015-10-29 13:32:05.641325] E [glusterfsd-mgmt.c:1814:mgmt_rpc_notify] 0-glusterfsd-mgmt: failed to connect with remote-host: localhost (Transport endpoint is not connected)
[2015-10-29 13:32:05.641351] I [glusterfsd-mgmt.c:1820:mgmt_rpc_notify] 0-glusterfsd-mgmt: Exhausted all volfile servers
[2015-10-29 13:32:05.641800] W [glusterfsd.c:1231:cleanup_and_exit] (-->/usr/local/lib/libgfrpc.so.0(rpc_clnt_notify+0xd2) [0x7fca20149af2] -->/usr/local/sbin/glusterfs() [0x40cd5f] -->/usr/local/sbin/glusterfs(cleanup_and_exit+0x4d) [0x407ddd] ) 0-: received signum (1), shutting down
[2015-10-29 13:32:05.641869] I [fuse-bridge.c:5686:fini] 0-fuse: Unmounting '/tmp/mntqxzdJu'.


Expected results:
vol replace-brick should work whether glusterd is bound to a specific IP or not

Additional info:
The issue has been discussed with Ravi (ravishankar@redhat.com) and Humble (hchiramm@redhat.com) and identified as localhost being hardcoded.
Comment 1 Vijay Bellur 2015-10-29 11:22:15 EDT
REVIEW: http://review.gluster.org/12461 (vol replace-brick fails when transport.socket.bind-address is set in glusterd) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-11-01 13:23:01 EST
REVIEW: http://review.gluster.org/12461 (vol replace-brick fails when transport.socket.bind-address is set in glusterd) posted (#2) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Vijay Bellur 2015-11-01 23:54:53 EST
REVIEW: http://review.gluster.org/12461 (glusterd : vol replace-brick fails when transport.socket.bind-address is set in glusterd) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Vijay Bellur 2015-11-02 00:35:04 EST
REVIEW: http://review.gluster.org/12461 (glusterd : vol replace-brick fails when transport.socket.bind-address is set in glusterd) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 5 Vijay Bellur 2015-11-02 23:38:44 EST
REVIEW: http://review.gluster.org/12461 (glusterd : vol replace-brick fails when transport.socket.bind-address is set in glusterd) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 6 Vijay Bellur 2015-11-03 03:37:12 EST
COMMIT: http://review.gluster.org/12461 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 76eaae58654560d5a2cc72f3a2de5934801a27e9
Author: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
Date:   Thu Oct 29 20:40:00 2015 +0530

    glusterd : vol replace-brick fails when transport.socket.bind-address is set in glusterd
    
    Change-Id: Id8c29aa46b526bc003a1d7023714b67805e35a99
    BUG: 1276386
    Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12461
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:42:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.