Bug 1276404 - Log message needs to be friendlier when AMQP credentials are not provided
Log message needs to be friendlier when AMQP credentials are not provided
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity low
: GA
: cfme-future
Assigned To: Julian Cheal
Ramesh A
amqp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 11:48 EDT by Ramesh A
Modified: 2017-08-21 09:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:04:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2015-10-29 11:48:41 EDT
Description of problem:
Log message needs to be friendlier when AMQP credentials are not provided

Version-Release number of selected component (if applicable):
5.5.0.8-beta1.4.20151027164951_4ab7fea

How reproducible:
100%

Steps to Reproduce:
1. Deploy and appliance
2. Manage RHOS infrastructure (Donot provide AMPQ credentials)
3. Check for the evm.log

Actual results:
Error files up in evm.log file (probably for every refresh event) as shown below: 

E, [2015-10-29T11:28:25.055232 #15899] ERROR -- #<Bunny::Session:110967360 admin@<provider_ip>:5672, vhost=/>: Authentication with RabbitMQ failed: 403 ACCESS_REFUSED - Login was refused using authentication mechanism PLAIN. For details see the broker logfile.


Expected results:
Error message should be caught and presented in a user friendly way stating "No AMQP credentials given, unable to connect to retrieve events" or something like that.

Additional info:
Comment 2 Joe Rafaniello 2016-03-08 08:55:47 EST
Greg, it looks like we could check this across the board for all providers where we have AuthUseridPassword types, at least where we require a username and password (not anonymous access types).  What do you think?
Comment 3 Chris Pelland 2017-08-21 09:04:14 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.