This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276407 - Unable to search for users by user ID when configured using ovirt-engine-extension-aaa-ldap
Unable to search for users by user ID when configured using ovirt-engine-exte...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-extension-aaa-ldap (Show other bugs)
3.5.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Bar-Lev
Ondra Machacek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 11:51 EDT by Greg Scott
Modified: 2016-02-10 14:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 06:07:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Scott 2015-10-29 11:51:03 EDT
Description of problem:
When ovirt-engine runs using ovirt-engine-aaa-ldap instead of rhevm-manage-domains, searching in the GUI for a user ID does not return any results. Searching by name works, but not user ID.

Version-Release number of selected component (if applicable):
3.5.z

How reproducible:
At will.

Steps to Reproduce:
1.  Set up ovirt-engine-extension-aaa-ldap to use an Active Directory domain
2.  Launch the RHEVM GUI
3.  Create a few users from the Active Directory domain above.
4.  Try to search for anyone by User ID.  Search comes up empty.
5.  Search by name works as expected.

Actual results:
See above - searching by ID comes up empty.  Searching by name works as expected.

Expected results:
Searching by ID should return results.

Additional info:
Comment 1 Alon Bar-Lev 2015-10-29 13:53:42 EDT
I think I already wrote you, put this in profile and try.
---
attrmap.map-principal-record.attr.PrincipalRecord_NAME.map = sAMAccountName
---

search now should work based on the sAMAccountName.
Comment 2 Greg Scott 2015-11-05 05:56:03 EST
Thanks for the reminder.  I just tried it on my test system and it worked.

- Greg

Note You need to log in before you can comment on or make changes to this bug.