Bug 1276420 - missing dependencies for epel
missing dependencies for epel
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-fedora (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 11:59 EDT by Michal Hlavinka
Modified: 2015-11-17 20:04 EST (History)
8 users (show)

See Also:
Fixed In Version: python-fedora-0.6.2-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 20:04:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2015-10-29 11:59:47 EDT
Description of problem:
can't import fedora.client.bodhi in EPEL7 maching with python2


Version-Release number of selected component (if applicable):
python-fedora-0.6.2-1.el7
python-requests-1.1.0-8.el7
python-urllib3-1.5-8.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.python
2.import fedora.client.bodhi

Actual results:
# python
Python 2.7.5 (default, Feb 11 2014, 07:46:25) 
[GCC 4.8.2 20140120 (Red Hat 4.8.2-13)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import fedora.client.bodhi
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/fedora/client/__init__.py", line 132, in <module>
    from fedora.client.openidbaseclient import OpenIdBaseClient
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 53, in <module>
    from requests.packages.urllib3.util import Retry
ImportError: No module named packages.urllib3.util


Expected results:
no import error

Additional info:
from urllib3.util import Retry
would fail too
Comment 1 Ralph Bean 2015-10-29 12:40:22 EDT
There should be a more modern version of python-requests in the rhel 7 repos.  Does upgrading to that help?
Comment 2 Michal Hlavinka 2015-10-30 04:31:09 EDT
Centos 7 repositories
http://ftp.linux.cz/pub/linux/centos/7/os/x86_64/Packages/
http://ftp.linux.cz/pub/linux/centos/7.1.1503/os/x86_64/Packages/
have python-requests-1.1.0-8.el7.noarch.rpm

Fedora EPEL7 and EPEL7-testing 
http://ftp.linux.cz/pub/linux/fedora/epel/7/x86_64/p/
http://ftp.linux.cz/pub/linux/fedora/epel/testing/7/x86_64/p/
does not have any python-requests package

I can see that python-requests-2.6.0-1.el7_1 should be available in RHEL7, so it seems that only centos is broken.

Anyway, if python-fedora requires some minimal version, it should specify it in spec file.

With python-requests 2.6.0 import works
Comment 3 Ralph Bean 2015-10-30 10:13:09 EDT
Thanks, and sorry for the trouble.  Retiring epel packages when they get absorbed into rhel can be tricky with respect to the timing of everything.

I've set the minimum version required to 2.6.0 and will ship an epel7 testing update soon.
Comment 4 Fedora Update System 2015-10-30 10:20:23 EDT
python-fedora-0.6.2-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-da3627f932
Comment 5 Fedora Update System 2015-11-01 11:50:17 EST
python-fedora-0.6.2-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update python-fedora'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-da3627f932
Comment 6 Miroslav Suchý 2015-11-04 10:13:43 EST
IMO you should put
  Requires: python-urllib3
directly into python-fedora.spec (even on Fedoras), because openidbaseclient.py calls urllib3.

The fact you requires python-request which should request urllib3, which need too, should not be excuse.
Comment 7 Fedora Update System 2015-11-17 20:04:26 EST
python-fedora-0.6.2-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.