Bug 1276423 - glusterd: probing a new node(>=3.6) from 3.5 cluster is moving the peer to rejected state
glusterd: probing a new node(>=3.6) from 3.5 cluster is moving the peer to ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Satish Mohan
:
Depends On:
Blocks: 1276541 1276905 1277822
  Show dependency treegraph
 
Reported: 2015-10-29 12:06 EDT by Anand Nekkunti
Modified: 2016-06-16 09:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1276541 1276905 1277822 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nekkunti 2015-10-29 12:06:20 EDT
Description of problem:

probing a new  node(>=3.6)  from 3.5 cluster is moving the peer to rejected state 



How reproducible:
Always

Steps to Reproduce:
probe the 3.7 node from 3.5 cluster, then 3.7 node moves to rejected state due to check sum mismatch
Comment 1 Vijay Bellur 2015-10-29 12:24:27 EDT
REVIEW: http://review.gluster.org/12464 (glusterd: fixing vol info checksum mismatch) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 2 Vijay Bellur 2015-10-30 07:22:46 EDT
REVIEW: http://review.gluster.org/12464 (glusterd: fix info file checksum mismatch during upgrade) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 3 Vijay Bellur 2015-10-30 09:46:00 EDT
REVIEW: http://review.gluster.org/12464 (glusterd: fix info file checksum mismatch during upgrade) posted (#3) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 4 Vijay Bellur 2015-11-01 01:52:45 EST
COMMIT: http://review.gluster.org/12464 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit d29dd0747dbb2e7383867c97cbbaa8c41851db78
Author: anand <anekkunt@redhat.com>
Date:   Thu Oct 29 21:36:57 2015 +0530

    glusterd: fix info file checksum mismatch during upgrade
    
    issue: probing a new  node(>=3.6)  from 3.5 cluster is moving the peer to rejected state.
    
    fix: Disperse vol support is added from 3.6 release, so write disperse fields (disperse_count=0
    and redundancy_count=0) in vol info file  only if cluster version supported.
    
    Change-Id: I11d5e2e337b9bbaddc8e52ca7295ba481beb1132
    BUG: 1276423
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/12464
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 8 Niels de Vos 2016-06-16 09:42:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.