Bug 1276441 - Unable to view the infinispan statistics from JBoss EAP 6 CLI
Unable to view the infinispan statistics from JBoss EAP 6 CLI
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.4.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chao Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 13:35 EDT by Ranjith Pulluru
Modified: 2017-02-07 14:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 17:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-5685 Major Open Register management resources for deployment-specific caches 2017-02-22 00:37 EST

  None (edit)
Description Ranjith Pulluru 2015-10-29 13:35:57 EDT
Description of problem:
=======================
 - Unable to view the infinispan statistics from JBoss EAP 6 CLI.

Version-Release number of selected component (if applicable):
==============================================================
 - JBoss EAP 6.4.x

Steps to Reproduce:
===================
1) Take a fresh JBoss EAP 6.4.3 installation and consider `standalone-ha.xml` file.
2) Enable the infinispan statistics in the standalone-ha.xml file.
   Configuration looks as below:
   -----
     <subsystem xmlns="urn:jboss:domain:infinispan:1.5">
 		:
            <cache-container name="web" aliases="standard-session-cache" default-cache="repl" module="org.jboss.as.clustering.web.infinispan" statistics-enabled="true">
                <transport lock-timeout="60000"/>
                <replicated-cache name="repl" mode="ASYNC" batching="true" statistics-enabled="true">
                    <file-store/>
                </replicated-cache>
                <replicated-cache name="sso" mode="SYNC" batching="true"/>
                <distributed-cache name="dist" l1-lifespan="0" mode="ASYNC" batching="true">
                    <file-store/>
                </distributed-cache>
            </cache-container>
               :
     </subsystem>   
   ----- 
3) Start the JBoss server with `standalone-ha.xml` file.
4) Deploy the cluster web application and hit the application.
5) and check the infinispan statistics by using the below cli command:
   -----
     /subsystem=infinispan/cache-container=web/replicated-cache=repl/:read-resource(include-runtime=true)
   -----
6) Values for the runtime parameters(i.e.,number-of-entries, hits, etc.,) never change. 

Actual results:
===============
- Values for the runtime parameters(i.e.,number-of-entries, hits, etc.,) never changed.

Expected results:
=================
- There should be a change in the runtime parameters values.

Additional info:
=================
- I can see the expected result from the jconsole statistics.
   jconsole -> mbean tab -> jboss.infinispan -> Cache -> $application -> web -> Statistics.

- Found a JDG bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1210176
Comment 3 Paul Ferraro 2015-11-16 11:48:42 EST
The underlying issue is that the cache instance used to store web session data for a deployed web application has no corresponding runtime management resource from which to obtain metrics. See https://issues.jboss.org/browse/WFLY-5685
Comment 5 Brad Maxwell 2016-06-28 17:03:59 EDT
Closing as this is a feature not a bug, see https://issues.jboss.org/browse/WFLY-5685

Note You need to log in before you can comment on or make changes to this bug.