This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276470 - [RHEV] Unable to perform Datastore SmartState Analysis: undefined method `ext_management_system
[RHEV] Unable to perform Datastore SmartState Analysis: undefined method `ext...
Status: CLOSED DUPLICATE of bug 1277302
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Rich Oliveri
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 15:10 EDT by Thom Carlin
Modified: 2015-11-17 00:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 00:06:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-29 15:10:34 EDT
Description of problem:

Performing a Datastore SmartState Analysis on RHEV results in: undefined method `ext_management_system

Version-Release number of selected component (if applicable):

5.5.0.8-beta1.4.20151027164951_4ab7fea

How reproducible:

100%

Steps to Reproduce:
1. Define RHEV provider with credentials
2. Refresh Relationships and Power States
3. Enter Credentials for Hosts
4. Perform Datastore SmartState Analysis

Actual results:

Configure > Tasks > My Other UI Tasks shows: 0 Storage Scans Pending; 0 of 0 Scans Complete
errors in logfile
No Drift History

Expected results:

Storage Scan successful
No errors in logfiles
Drift History

Additional info:

evm.log excerpt:

[----] I, [2015-10-29T14:54:45.821366 #17058:f1f98c]  INFO -- : MIQ(Storage.create_scan_task) Created MiqTask ID: [5508000000000002], Name: [SmartState Analysis for [domain_name]]
[----] I, [2015-10-29T14:54:45.839863 #17058:f1f98c]  INFO -- : <AutomationEngine> MiqAeEvent.build_evm_event >> event=<"request_storage_scan"> inputs=<{"MiqEvent::miq_event"=>5508000000000188, :miq_event_id=>5508000000000188, "EventStream::event_stream"=>5508000000000188, :event_stream_id=>5508000000000188}>
[----] W, [2015-10-29T14:54:45.841401 #17058:f1f98c]  WARN -- : MIQ(Storage.scan_queue) Storage name: [domain_name], id: [5508000000000001]: rejected for scan because <undefined method `ext_management_system' for #<Storage:0x0000001213e590>> - removing from target list
Comment 2 Dave Johnson 2015-11-17 00:06:24 EST

*** This bug has been marked as a duplicate of bug 1277302 ***

Note You need to log in before you can comment on or make changes to this bug.