Bug 1276479 - Deleting composite view version fails with TypeError: Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject
Deleting composite view version fails with TypeError: Value (NilClass) '' is ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
medium Severity high with 1 vote (vote)
: Beta
: --
Assigned To: Brad Buckingham
Lukas Pramuk
http://projects.theforeman.org/issues...
: PrioBumpGSS, Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 15:45 EDT by Chris Roberts
Modified: 2017-05-23 09:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:20:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 9 Brad Buckingham 2016-04-04 14:32:54 EDT
Created redmine issue http://projects.theforeman.org/issues/14465 from this bug
Comment 10 Brad Buckingham 2016-04-04 14:58:47 EDT
Upstream Katello PR:  https://github.com/Katello/katello/pull/5937
Comment 11 Bryan Kearney 2016-04-04 16:04:30 EDT
Upstream bug component is Content Management
Comment 12 Lukas Pramuk 2016-04-13 09:24:25 EDT
VERIFIED.

@Sat6.2.0-Beta-Snap7

1. synced RHEL7, Sat Tools 6.1
2. for each repo created CV and published them
3. created composite CV out of them and published version
4. deleted published version

Successfully initiated removal of Composite1 version 1.0.

Successfully removed Composite1 version 1.0 from environments: Library
Comment 14 errata-xmlrpc 2016-07-27 05:20:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.